Apache startet nich ...

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache startet nich ...

Postby Ecky » 05. February 2004 14:19

Hi , hab nen Prob. bin totaler n00b was das hier angeht. Hab mir einer XAMPP Pack runtergeladen und installiert wie es beschrieben steht. Jetzt starte ich die "apache_start.bat" und er schreibt mir folgendes :
Apache 2 is starting ...
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to
address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Wäre nett wenn mir einer helfen könnte was hier nicht funzt.
Ecky
 
Posts: 2
Joined: 05. February 2004 14:12

Postby DJ DHG » 05. February 2004 14:26

Moin Moin

die SuFu wird dir garantiert helfen! und die FAQ auch!

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Ecky » 05. February 2004 14:43

^^ thx . hab ich übersehen. Habs gefunden
Ecky
 
Posts: 2
Joined: 05. February 2004 14:12

Postby gfxrocker » 09. February 2004 15:07

DJ DHG wrote:Moin Moin

die SuFu wird dir garantiert helfen! und die FAQ auch!

mfg DJ DHG


die FAQ meint dazu:
could not bind to address 0.0.0.0:80

Diese Fehlermeldung bedeutet das der Port 80, auf dem der Apache Standardgemäß läuft,
schon von einer anderen Anwendung belegt wird. Dies kann ein anderer Apache, der IIS
oder auch ein anderer Webserver sein.


Super tolle Antwort: Wusste ich auch schon vorher und hilft mir kein bisschen mein Problem zu lösen.

Ich war so dumm und hatte den Apache als Service installiert dann hab ich den Fehler gemacht und hab de Service deinstalliert ohne vorher Apache zubeenden. Und jetzt werde ich immer mit dieser Fehlermeldung konfrontiert. Nur wo wie was muss man da machen. Wäre schön wenn es dabei stehen würde und nicht nur die Fehlermeldung eindeutscht.
gfxrocker
 
Posts: 4
Joined: 09. February 2004 15:01

Postby DJ DHG » 09. February 2004 15:50

gfxrocker wrote:Super tolle Antwort: Wusste ich auch schon vorher und hilft mir kein bisschen mein Problem zu lösen.

Ich war so dumm und hatte den Apache als Service installiert dann hab ich den Fehler gemacht und hab de Service deinstalliert ohne vorher Apache zubeenden. Und jetzt werde ich immer mit dieser Fehlermeldung konfrontiert. Nur wo wie was muss man da machen. Wäre schön wenn es dabei stehen würde und nicht nur die Fehlermeldung eindeutscht.


deswegen habe ich ja auch auf die SuFu hingewiesen! so oft wie das hier
besprochen wird es schon fast irre!

es gibt nur einen grund warum diese fehlermeldung auftaucht (port blockiert), aber es
gibt viele ursachen wo durch sie erst entsteht (das prog welches den port
blockiert) . deswegen gibt es keine pauschale antwort!

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby gfxrocker » 09. February 2004 15:53

Das Programm das den Port blockiert ist der fehlerhaft deinstallierte Apache. Das weiss ich aber wo knn ich da was verändern!
gfxrocker
 
Posts: 4
Joined: 09. February 2004 15:01

Postby DJ DHG » 09. February 2004 15:59

ich bin zwar kein windows experte, aber wenn er nicht mehr im
autostart drin ist sollte doch ein reboot oder ein einfacher stop helfen?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby gfxrocker » 09. February 2004 16:28

Hab ich mir auch gedacht aber ich hab keine apache_stop datei. Nur apache_start hab auch schon xamp neu installiert und x-mal reboot in der autostart ist kein apache drin
gfxrocker
 
Posts: 4
Joined: 09. February 2004 15:01

Postby DJ DHG » 09. February 2004 16:44

wenn du ein NT basiertes windows hast, schau mal taskmanager nach
ob es da eine prozess namend apache gibt (könne auch mehrere sien)
und kill ihn.

in der CMD im apache\bin ordner
Code: Select all
apache -k stop


was passiert dann?

und besorg die mal das prob "Active Ports" damit kannst d nach schauen
welches programm welchen port belegt..

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests