Apache wartet 45s

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache wartet 45s

Postby Plasm » 14. October 2010 09:47

Hallo,

Mein Apache liefert ab und an eine Webseite (php) erst nach 45s aus. Das passiert bei ca 100 Seiten-Aufrufen pro Tag etwa 1-5x. Direkt danach (und auch davor) läuft alles normal. Soll heißen: ich klicke mich z.B. durch 5 Dateien und nur beim Aufruf der 2. Datei dauert es 45s. Wenn ich danach die Datei erneut anfrage (z.B. über F5) antwortet der Apache sofort (Datei wird nicht im Browser gecached).
Das Problem haben auch andere Rechner die im selben Netz hängen. Eine Netzwerkstörung liegt nicht vor - der Server an sich ist während der 45s Wartezeit ständig erreichbar. Die Last des Servers steigt auch nicht an.

Im Log steht dann zb:
Code: Select all
1.1.1.1 - - [14/Oct/2010:09:29:55 +0200] "GET /index.php HTTP/1.1" 200 88884
1.1.1.1 - - [14/Oct/2010:09:30:40 +0200] "GET /css/screen.css HTTP/1.1" 304 -


Ein Mitschnitt mit Wireshark sieht so aus:
Code: Select all
Nr   Time         Source       Destination   Protocol    Info
4    11.114392    1.1.1.1      2.2.2.2       HTTP        GET /index.php HTTP/1.1
5    11.114659    2.2.2.2      1.1.1.1       TCP         http > 50141 [ACK] Seq=405 Ack=533 Win=2131 Len=0
6    56.153570    2.2.2.2      1.1.1.1       TCP         [TCP segment of a reassemled CPU]
7 ... weitere Pakete


Als nächstes habe ich noch in die php-Datei ganz am Anfang und ganz am Ende die Uhrzeit in eine Logdatei geschrieben (um zu prüfen, ob das Script an sich eine lange Laufzeit hat). Die Differenz der beiden Zeiten (also die Laufzeit) beträgt allerdings nur 14ms.

Es sieht also so aus, als würde der Apache die Datei erst nach 45s ausliefern. Ich weiß aber nicht warum. In den .conf-Dateien habe ich alle Stellen an denen der Text "45" auftaucht schon abgesucht.

Hat jemand eine Idee wo das Problem liegen könnte oder was ich noch testen könnte ?

Danke und Gruß
Plasm
Plasm
 
Posts: 4
Joined: 14. October 2010 08:45

Re: Apache wartet 45s

Postby Plasm » 15. October 2010 12:42

Der Apache wurde gerade auf die neuste Version (2.2.16) aktualisiert, doch leider besteht das Problem immer noch.
Was ich noch rausgefunden habe: Das php-Script wird erst am Ende der 45s Wartezeit ausgeführt. Schematisch also quasi so:

Code: Select all
0,0s GET Anfrage an php-Datei
0,1s ACK vom Server
45,0s Verarbeitung des PHP-Scripts beginnt
45,1s Verarbeitung des PHP-Scripts endet
45,2s HTML wird an den Client geschickt

Ich habe nun echt keine Idee mehr, was ich noch probieren könnte. Kann jemand helfen ?
Plasm
 
Posts: 4
Joined: 14. October 2010 08:45

Re: Apache wartet 45s

Postby Nobbie » 15. October 2010 13:26

Plasm wrote:Kann jemand helfen ?


Wie soll das möglich sein?
Nobbie
 
Posts: 8777
Joined: 09. March 2008 13:04

Re: Apache wartet 45s

Postby Plasm » 15. October 2010 13:31

Das war jetzt nicht hilfreich...
Plasm
 
Posts: 4
Joined: 14. October 2010 08:45

Re: Apache wartet 45s

Postby Nobbie » 15. October 2010 14:14

Das sind Deine komplett fehlenden Angaben auch nicht.

Wie soll man denn helfen, wenn man NICHTS(!!!) über die Installation weiß?

Nicht einmal das Betriebssystem ist uns bekannt. Keine einzige Konfiguration ist uns bekannt, keine einzige Zeile PHP Code ist uns bekannt, keine PHP Version, sind Cachingtools im Einsatz, wie wird PHP betrieben (Module, CGI, FastCGI), sind Beschleunigungstools im Einsatz (eAccelerator), keinerlei Datenbankinformationen liegen vor, keinerlei Hardwareinformationen, keinerlei Netzinformationen usw. etc. pp. - nichts, Null, de nada, niente, gar nichts.

Apache 2.2.16 und 45s bei (manchen?) PHP Scripten - das ist alles, was wir wissen.
Nobbie
 
Posts: 8777
Joined: 09. March 2008 13:04

Re: Apache wartet 45s

Postby Plasm » 15. October 2010 14:33

Nobbie wrote:Apache 2.2.16 und 45s bei (manchen?) PHP Scripten
Nein, nicht bei manchen, sondern bei allen - aber nicht bei jedem Aufruf. Evtl. besteht das Problem auch bei nicht php-Dateien. Das konnte ich bisher noch nicht genau nachvollziehen.

PHP-Code bzw Datenbankinformationen sind hier nicht relevant, da ich ja schon getestet habe, ob es am Inhalt der Datei liegt oder nicht. Da die PHP-Datei an sich innerhalb weniger ms abgearbeitet ist, ist es auch egal ob ich innerhalb diesen Codes auf eine DB zugreife oder nicht.

So wie es den Anschein hat, ist es ein reines Apache-Problem, daher habe ich auch keine Informationen angegeben die ich für nicht relevant hielt.
Server: SUSE Linux Enterprise Server 10 (i586) - Kernel 2.6.16.21-0.8-smp
Keine Beschleunigungstools, keine Cachingtools. Hardwareinformationen habe ich keine, die muss ich erst nachfragen. Ist jedenfalls nix wirklich neues.

Konfiguration ist vermutlich das Stichwort: Allerdings weiß ich nicht was davon interessant ist. Ich kann am Montag mal versuchen ins Blaue zu raten und einen Teil der Konfiguration posten, die ich für vermutlich interessant halte
Plasm
 
Posts: 4
Joined: 14. October 2010 08:45


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests