DocumentRoot zeigt keine Wirkung

Alles, was den Apache betrifft, kann hier besprochen werden.

DocumentRoot zeigt keine Wirkung

Postby ZodiacXP » 10. October 2010 12:27

Servus.

Es wurde DocumentRoot geändert und der Directory-Eintrag angepasst, so dass der Zugriff gesichert ist.
Nach mehreren Neustarts des Apache und Kontrollen der httpd.conf zeigt Apache keine Wirkung!

Es bleibt bei dem alten DocumentRoot der mit der Installation ausgeliefert wird. Hat XAMPP irgendwo eine Konfiguration versteckt, welche keine Änderung zulässt?
ZodiacXP
 
Posts: 21
Joined: 01. August 2005 07:01
Location: In einem Haus

Re: DocumentRoot zeigt keine Wirkung

Postby Nobbie » 10. October 2010 12:41

Nö, aber der Browser hat einen Cache...
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: DocumentRoot zeigt keine Wirkung

Postby ZodiacXP » 10. October 2010 23:19

Hehe, ok das wäre ein Anfängerfehler aber keine Sorge, als sehr Erfahrener schau ich dort bei Fehlern nicht mehr nach ;)
Sehe in den Logs noch den alten DocumentRoot weil er ein entsprechendes 404 schmeißt.

Apache HTTP mit PHP selbst aufgesetzt: Kein Problem beim umschreiben des DocumentRoot.
XAMPP: Problem - Warum?

P.S. : Auch wenn ich das selbst aufsetzen kann, möchte ich hierbei mit der XAMPP-Lösung arbeiten.
ZodiacXP
 
Posts: 21
Joined: 01. August 2005 07:01
Location: In einem Haus

Re: DocumentRoot zeigt keine Wirkung

Postby Nobbie » 11. October 2010 13:02

Entweder startest Du den falschen Apache, oder bearbeitest die falsche httpd.conf, oder hast einen doppelten DocumentRoot Eintrag oder hast eine Kopie von httpd.conf angelegt (meistens mit Notepad, der dann httpd.conf.txt daraus macht).

Welches Windows benutzt Du, wo ist Xampp installiert, wo befindet sich die httpd.conf, welches Änderungsdatum zeigt der Explorer an?
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: DocumentRoot zeigt keine Wirkung

Postby ZodiacXP » 11. October 2010 17:59

Win Vista, XAMPP auf USB mit relativen Pfaden, Konfig in /xampp/apache/conf, immer die aktuelle Zeit nach dem ändern.

Das Ding hats irgendwie gefressen. Selbst nach einer komplett leeren Konfiguration wurde nicht mal ein Fehler geschmissen.
Habe mit notepad, Notepad++, eclipse und allerlei kram die Konfig geändert - nichts passierte.

Also: Platt machen und XAMPP nochmal drauf. Würd mich echt interessieren was das war, denn nun gehts wie gewohnt.
Vielleicht habe ich irgendwo ganz versteckt eine htaccess übersehen, aber die müsst durch Zauberhand entstanden sein :P

Und wie immer löst sich das ganze von selbst ohne Grund... oder mit anderen Worten: Informatiker-Alltag
ZodiacXP
 
Posts: 21
Joined: 01. August 2005 07:01
Location: In einem Haus

Re: DocumentRoot zeigt keine Wirkung

Postby Nobbie » 11. October 2010 21:09

ZodiacXP wrote:Und wie immer löst sich das ganze von selbst ohne Grund... oder mit anderen Worten: Informatiker-Alltag


Ne, definitiv nicht. Es ist eine Frage des Informatikers, ob das "von selbst ohne Grund" passiert, oder ob man den Fehler findet. Ich könnte mit so einer Einstellung nicht leben.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests