.HTACCESS mit LDAP-Authentifizierung gegen Win2003 ADS

Alles, was den Apache betrifft, kann hier besprochen werden.

.HTACCESS mit LDAP-Authentifizierung gegen Win2003 ADS

Postby Andy74 » 17. September 2010 08:38

Hallo zusammen,

ich weiß, dass es hier schon einige Threads zu diesem Thema gibt, die habe ich auch schon alle durch, trotzdem habe ich ein Problem.
Ich möchte ein Verzeichnis auf unserem Apache 2.2 Webserver gegen die Win2003 ADS Authentifizieren.

Folgender Code funktioniert schon mal. Da kommen alle Benutzer in das Verzeichnis.


Code: Select all
AuthName "Test"
AuthType Basic
AuthBasicProvider ldap
AuthzLDAPAuthoritative Off
AuthLDAPURL ldap://server.domain.com:389/DC=xxx,DC=domain,DC=com?sAMAccountName?sub?(objectClass=*)
AuthLDAPBindDN "CN=testuser,OU=testgruppe,OU=Users,DC=XXX,DC=domain,DC=com"
AuthLDAPBindPassword "start"
AuthLDAPGroupAttributeIsDN On
Require valid-user



Wir möchten aber nur bestimmte Benutzer zulassen.
Folgender code funktioniert nicht.

Code: Select all
AuthName "Test"
AuthType Basic
AuthBasicProvider ldap
AuthzLDAPAuthoritative Off
AuthLDAPURL ldap://server.domain.com:389/DC=xxx,DC=domain,DC=com?sAMAccountName?sub?(objectClass=*)
AuthLDAPBindDN "CN=testuser,OU=testgruppe,OU=Users,DC=XXX,DC=domain,DC=com"
AuthLDAPBindPassword "start"
AuthLDAPGroupAttributeIsDN On
Require ldap-group CN=gruppenname,OU=test,DC=xxx,DC=domain,DC=com


genauso wenig funktioniert

Code: Select all
AuthName "Test"
AuthType Basic
AuthBasicProvider ldap
AuthzLDAPAuthoritative Off
AuthLDAPURL ldap://server.domain.com:389/DC=xxx,DC=domain,DC=com?sAMAccountName?sub?(objectClass=*)
AuthLDAPBindDN "CN=testuser,OU=testgruppe,OU=Users,DC=XXX,DC=domain,DC=com"
AuthLDAPBindPassword "start"
AuthLDAPGroupAttributeIsDN On
Require ldap-user user123



Bei beiden Beispielen kommt im Browser zwar ein Windows-Anmeldefenster, nach dem Eingeben des ADS-Benutzers kommt dann aber "Authentifizierung fehlgeschlagen" (error 401)


Irgendwelche Tipps woran das Problem liegen könnte?
Wenn das Beispiel mit dem "REQUIRE VALID-USER" funktioniert, müsste die LDAP Geschichte an sich ja schon mal funktionieren, oder?
Andy74
 
Posts: 14
Joined: 04. June 2007 13:12

Re: .HTACCESS mit LDAP-Authentifizierung gegen Win2003 ADS

Postby Andy74 » 17. September 2010 09:29

Im ERROR.LOG des Apache Servers findet sich folgendes.

Also den Benutzer, der die LDAP Abfrage ausführen soll, gibt es definitiv in der ADS.


[Fri Sep 17 10:25:26 2010] [debug] mod_authnz_ldap.c(972): [3588] auth_ldap url parse: `ldap://server.domain.com:389/DC=server,DC=daimain,DC=com?sAMAccountName?sub?(objectClass=*)', Host: server.domain.com:389, Port: 389, DN: DC=server,DC=domain,DC=com, attrib: sAMAccountName, scope: subtree, filter: (objectClass=*), connection mode: not using SSL

[Fri Sep 17 10:25:26 2010] [debug] mod_authnz_ldap.c(599): [client 10.254.129.131] ldap authorize: Creating LDAP req structure

[Fri Sep 17 10:25:26 2010] [debug] mod_authnz_ldap.c(611): [client 10.254.129.131] auth_ldap authorise: User DN not found, User not found
Andy74
 
Posts: 14
Joined: 04. June 2007 13:12


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests