Dateien lassen sich mit FTP nicht überschreiben

Alles, was den Apache betrifft, kann hier besprochen werden.

Dateien lassen sich mit FTP nicht überschreiben

Postby Kreidler » 27. February 2003 21:30

Hi, brauche mal nen Tritt in die richtige Richtung. Habe letztens Lampp installiert. Seiten von meiner Win-Kiste mittels Wise-Ftp auf den Apachen geschaufelt, gelöscht, zurückgeholt. Klappt wunderbar!
Aber: :oops: Dateien auf dem Apachen können nicht überschrieben werden!
Eigentlich sollte das laut ProFtpd.conf doch Standard sein. Die Rechte an den Dateien habe ich (chmod 774).

Danke im vorraus

Kreidler
Kein Beitrag ist unnütz: er kann immer noch als schlechtes Beispiel dienen!
Kreidler
 
Posts: 4
Joined: 16. February 2003 01:46
Location: Bergkamen

Re: Dateien lassen sich mit FTP nicht überschreiben

Postby linux.apache » 01. March 2003 16:22

Kreidler wrote:Seiten von meiner Win-Kiste mittels Wise-Ftp auf den Apachen geschaufelt, gelöscht, zurückgeholt. Klappt wunderbar!
Aber: :oops: Dateien auf dem Apachen können nicht überschrieben werden! Eigentlich sollte das laut ProFtpd.conf doch Standard sein.


Aähm, ich bin mir nicht sicher, ob ich Dich richtig verstanden habe :wink: aber wie schaut´s mit den Berechtigungen für Deinen Wise-Ftp-Account auf dem apache aus ? Vielleicht erlaubt es apache nicht, weil die hochgeladenen Seiten einem anderen account gehören als apache selber (nobody.nobody) aber wenn ich genauer drüber nachdenke, hab ich eigentlich kein Plan, wie das alles unter win gehandhabt wird (ohne cygwin ???) und weil ich mir weiterhin nicht vorstellen kann, einen apache auf win aufzusetzen :shock: und das auch noch nie getan habe :arrow: GooD LucK
Praxis:Jeder kann´s, aber keiner weiß wie´s geht...
Theorie:Jeder weiß wie´s geht, aber keiner kann´s ...
Microsoft vereint Praxis und Theorie : Nix geht und keiner weiß warum ;-)
User avatar
linux.apache
 
Posts: 25
Joined: 27. February 2003 00:41
Location: Berlin-Kreuzberg

Postby Oswald » 01. March 2003 16:33

Hallo Kreidler!

Welche LAMPP-Version benutzt Du? Ich das wissen, damit es mit genau der gleichen Version mal ausprobieren kann.. ;)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Unklar ausgedrückt?

Postby Kreidler » 02. March 2003 23:48

Tut mir leid, liebe Freunde, wenn ich mich unklar ausgedrückt habe. :wink: Also, istalliert habe ich den lampp-0.9.7 auf einer SUSE 8.0-Kiste als Server. Der Windoof mit Wise-FTP ist der Client.
Angelegt wurde eine eigene Partition, gemountet auf /daten, darin ein Verzeichnis /WWW ( :arrow: chown peter WWW, chgrp www WWW, chmod 774 WWW).
Außer dem ServerName wurde die httpd.conf abgeändert in

DocumentRoot "/daten/WWW"
und
#<Directory "/opt/lampp/htdocs">
in
<Directory "/daten/WWW">

Vom Windows-Client bekam ich erst nur eine Verbindung zum Stammverzeichnis :roll: von lampp, aber nach dem ich die proftpd.conf angepasst hatte, konnten alle user, die unter Linux zur Gruppe "www" gehören, sich von jedem beliebigen Client im Netz mit ihrem Linux-Kennwort FTP-mäßig am Verzeichnis WWW anmelden, Seiten hoch- und runterladen und auch wieder löschen.
Was keiner kann ist seine Seiten auf dem Client ändern und dann mit FTP hochladen. Das aktuallisieren, sprich überschreiben ist nicht erlaubt!
In der proftpd.conf ist das ausdrücklich erlaubt, was ja auch Sinn macht. Habe mal die Serverweiten Default-Rechte auf

<Directory />
Options FollowSymlinks
AllowOverride All
>/Directory>

geändert, ohne Ergebnis. Aber ich denke, irgendwo in dieser Rechtevergabe muss ich wohl was übersehen haben. Herzlichen Dank für eure Mühen.
Kein Beitrag ist unnütz: er kann immer noch als schlechtes Beispiel dienen!
Kreidler
 
Posts: 4
Joined: 16. February 2003 01:46
Location: Bergkamen

Postby Oswald » 03. March 2003 11:11

Moin Kreidler!

Schreib doch mal folgendes in Deine proftpd.conf

<Directory /daten/WWW/*>
AllowOverwrite on
</Directory>


Geht's?

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Geht!

Postby Kreidler » 03. March 2003 18:58

Wie konnte ich nur übersehen, das zu der Default-Freigabe in der proftpd.conf auch ein Default-Pfad gehört. :oops: Anfänger!!!

Ich wandelte blind durch das Land doch der Herr :idea: hat mich sehend gemacht.
Lieber Oswald, vielen Dank für die prompte Hilfe
Kein Beitrag ist unnütz: er kann immer noch als schlechtes Beispiel dienen!
Kreidler
 
Posts: 4
Joined: 16. February 2003 01:46
Location: Bergkamen

Postby Guest » 17. May 2003 03:12

hi

in meine proftp.con ist folgende eintrag

Code: Select all
<Directory /opt/lampp/htdocs/*>
  AllowOverwrite      on
</Directory>


überschreiben geht aber trotzdem nich ?
Guest
 

Postby tekknozid » 17. May 2003 12:31

sorry. der beitrag war auch von mir...
hat einer ne idee ?
tekknozid
 
Posts: 82
Joined: 17. May 2003 03:17

Postby tekknozid » 20. May 2003 01:23

please help ! :-)
tekknozid
 
Posts: 82
Joined: 17. May 2003 03:17

Postby Oswald » 20. May 2003 09:22

Huhu partyjunk!

Was für eine Fehlermeldung kommt genau?
Was passiert, wenn Du folgendes probierst: neue Datei via FTP hochladen und dann noch mal erneut die gleiche Datei hochladen und damit die ersthochgeladene überschreiben.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby tekknozid » 21. May 2003 15:32

Was für eine Fehlermeldung kommt genau?


550 test: Overwrite permission denied

Was passiert, wenn Du folgendes probierst: neue Datei via FTP hochladen und dann noch mal erneut die gleiche Datei hochladen und damit die ersthochgeladene überschreiben.


ich bekomme obige fehlermeldung.
sprich ich kann nicht überschreiben.
erst löschen und dann hochladen funktioniert.
tekknozid
 
Posts: 82
Joined: 17. May 2003 03:17


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest