Linux : Apache startet nicht?!?!?!

Alles, was den Apache betrifft, kann hier besprochen werden.

Linux : Apache startet nicht?!?!?!

Postby Fracoon » 26. January 2004 20:05

Ich habe Lampp wie in der Anleitung beschrieben installiert und gestartet. Beim starten erhalte ich keine Fehlermeldung.

Aber der Apache läuft nicht. Wenn ich unter webmin den serverstatus anzeigen lasse steht da das Apache nicht aktiviert ist...

Irgendwer ne lösung??
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby Cyborg » 26. January 2004 20:14

schau ma in task manager, ob da der Apache läuft !
Cyborg
 
Posts: 4
Joined: 26. January 2004 16:08

Postby Fracoon » 26. January 2004 20:19

taskmanager unter linux???
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby Fracoon » 26. January 2004 20:20

wenn ich bei den laufenden prozessen nachsehe is er da auch nicht... also kein apache am laufen
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby Fracoon » 26. January 2004 20:23

und ein portscann sagt mir das port 80 nich offen is.... wobei ftp port und so sind offen... funzt auch.. nur der apache nich....
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby Cyborg » 26. January 2004 20:42

ach ups *GGGG*
ich les immer, apache startet nicht :wink:
Cyborg
 
Posts: 4
Joined: 26. January 2004 16:08

Postby DJ DHG » 27. January 2004 00:52

Moin Moin

was steht in den error logs von apache?

mfg DJ DHG

PS: grafischen taskmanager unter KDE geht mit Strg + Esc.
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Fracoon » 27. January 2004 13:43

Wo kann ich die error logs finden? Hab kein KDE instaliert. Nur Konsole...
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby DJ DHG » 27. January 2004 13:44

die sind unter

Code: Select all
/opt/lampp/logs


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Fracoon » 27. January 2004 13:53

error_log :

[Mon Jan 26 12:01:39 2004] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 26 12:01:40 2004] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 26 12:01:40 2004] [notice] Digest: done
[Mon Jan 26 12:01:41 2004] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)
[Mon Jan 26 12:35:09 2004] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 26 12:35:10 2004] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 26 12:35:10 2004] [notice] Digest: done
[Mon Jan 26 12:35:11 2004] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)



[/b]
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby Fracoon » 27. January 2004 13:55

und dann gibts noch mehrere dateien .. die sind aber alle leer... auser die datei httpd

da steht drin :

3502
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby DJ DHG » 27. January 2004 14:30

User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby blueser » 28. January 2004 10:13

Hi,

versuche doch den Apache manuel von der Kommandozeile zu starten. Jenachdem wo dein Installationspfad sich befindet gebe den Befehl z.B.:

/usr/local/apache/bin/apachectl start.

mit apachectl stop kannst du ihn stoppen. Und was murmelt er?

fehlt Ihm nichts, also startet er problemlos, kannst du ihn automatisch starten lassen, ich gehe davon aus du arbeitest mit SuSE Linux. Erstelle 2 Links in dem /etc/init.d/rc3.d einen um ihn zu starten: also zu erst:

cd /etc/init.d/rc3.d und dann

ln -s /usr/local/apache/bin/httpd S20apachestart

und einen um ihn zu stoppen

ln -s /usr/local/apache/bin/httpd K20apachestop

somit sollte er beim erreichen des Level3 den autom. starten.

Schönen Gruß blueser
blueser
 
Posts: 24
Joined: 12. January 2004 09:41
Location: HH, DE

Postby Fracoon » 28. January 2004 14:11

die antwort von DJ DHG hat des problem schon gelöst
Fracoon
 
Posts: 8
Joined: 26. January 2004 20:02

Postby blueser » 28. January 2004 19:44

das finde ich super!
blueser
 
Posts: 24
Joined: 12. January 2004 09:41
Location: HH, DE


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests