http_host

Alles, was den Apache betrifft, kann hier besprochen werden.

http_host

Postby Mario Lanz » 11. June 2010 19:10

Hallo

Ich hatte/habe ein Problem mit the thumbnails auf einer Seite von mir, die ich am aufbauen bin...

Der Fehler war folgender:
Image

Gemäss dieser Fehlermeldung stimmt etwas nicht mit meiner http_host.

Nur, diese Datei habe ich noch nie gesehen.
Leider kann ich weder mit http noch host suche, da es diesbezüglich 1000..... Beiträge gibt.

Gibt es irgendwo ein Wiki oder wäs ähnliche dazu, wo beschrieben wird, was diese Datei macht resp. zu was diese dient?

oder kann dies jemand in zwei drei Worten erklären?

Vielen Dank

Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Re: http_host

Postby Nobbie » 12. June 2010 09:42

Mario Lanz wrote:Gemäss dieser Fehlermeldung stimmt etwas nicht mit meiner http_host.


Zeigst Du uns die falsche Meldung? Da steht NullkommaNull (also wirklich nicht einmal eine Silbe, kein Fragment, nichts, rein gar nichts) von "http_host", auch nicht "host" und auch nicht "http". Da steht etwas total anderes und das kann man ja schon am Funktionsnamen erkennen, was die Funktion tut und warum sie sich nun zu Wort meldet.

Mario Lanz wrote:Nur, diese Datei habe ich noch nie gesehen.


Hä? Es wird wirklich immer wilder - welche Datei? Da steht nichts, rein gar nichts, wieder einmal wirklich nicht ein Sterbenswörtchen von einer Datei?

Bist Du sicher, Du zeigst uns dir richtige Meldung. Ich tippe sie mal ab, vielleicht klärt das ja ein Mißverständnis auf:

Code: Select all
phpThumb() v1.7.9-200805132113

AntiOffsiteLinking() - "www.mala-computing.com" is NOT in
$this->config_nooffsitelink_valid_domains (77.72.71.66)


Was da passiert, ist doch offensichtlich.

Mario Lanz wrote:Leider kann ich weder mit http noch host suche, da es diesbezüglich 1000..... Beiträge gibt.


Wieso suchst Du nicht nach "Banane" und "Plasmafernseher"? Steht auch nichts von in der Meldung drin.

Mario Lanz wrote:Gibt es irgendwo ein Wiki oder wäs ähnliche dazu, wo beschrieben wird, was diese Datei macht resp. zu was diese dient?


Welche Datei?


Mario Lanz wrote:oder kann dies jemand in zwei drei Worten erklären?


Das ist doch wirklich offensichtlich - oder kannst Du keinerlei Englisch, das würde natürlich auch erklären, warum Du den Wald vor Bäumen nicht siehst?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: http_host

Postby Mario Lanz » 12. June 2010 09:59

Hallo Nobbie

Das Problem habe ich gelöst, indem ich in der phpthumb.config.php Datei das offsitelinking angepasst habe (von true auf false umgestellt).

Jetzt erscheinen die Thumbnails auf der Newsseite wieder. Vorhin wurde anstatt der Thumbnails das oben geposteted Bild angezeigt.

Ich habe dann im Forum nachgefragt, von wo ich das Theme/Design her habe und dies war die Antwort:
It's a configuration issue - either of your server or e107. Beam widget is not adding domain to the thumbnail path (it creates relative paths). So you maybe set the path (main site config) from '/' to 'yourdomain.com/'.
Even in this case, phpThumb should know that yourdomain.com is your domain ($_SERVER['HTTP_HOST']) and it doesn't do that, which makes me think HTTP_HOST of your server is not proper set for some reason.
In the end - you provoked parse error with changes you made to the configuration variable - it contains bad formed string and array. Both settings are not security related, they protect you from bandwitdh and processor thefts.


und weil dort auf die Http_Host verwiesen wird, dachte ich mir, dass es sich um eine Datei handeln müsste, die so heisst.

In diesem Fall muss ich mich irren, wenn ich deine Antwort sehe...

Was ich von http ableite wäre einerseit die httpd.conf datei oder host = host datei im windows/system32... oder die vhosts im extra ordner vom apache.


Aus diesem Grund dachte ich es seine Datei.

Könntest du mir nun sagen, nach was ich dann suche?

Danke

Gruss mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Re: http_host

Postby Xardas der Dunkle » 12. June 2010 10:42

$_SERVER['HTTP_HOST'] hat absolut nix mit einer Datei zu tun. In dieser Variable steht der Domain-Name mit dem du die Seite aufgerufen hast.
Also der domain-name unter dem deine Seite erreichbar ist.

Und dein Thubnail-Script überprüft diesen um zu verhindern das Bilder von externen Servern eingebunden werden.
Du musst in der Config-Datei irgendwo deinen Domain-Namen hinterlegen ...
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: http_host

Postby Mario Lanz » 12. June 2010 11:12

aha - danke

Nur leider hat auch das nichts gebracht, habe beide URL's und auch die IP hinterlegt im phpthumb.config.php - brachte leider nichts.

Kann man irgendwie definieren, wie und was in der http_host steht?

Also, das "Problem" ist, dass ich ja auf meiner Umgebung viele vhosts habe - könnte evtl. dort ein Problem bestehen?

Das Problem ist auch erst aufgetreten, als ich von der XAMPP 1.7.3 wieder zurück auf die Version 1.7.1 gegangen bin - wegem PHP 5.3.x
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests