Reverse Proxy mit Exchange will 2 Authorisierungen

Alles, was den Apache betrifft, kann hier besprochen werden.

Reverse Proxy mit Exchange will 2 Authorisierungen

Postby bemar » 05. May 2010 10:49

Hallo,

ich habe ein recht komisches Verhalten und hoffe ihr habt eine Idee.

Ich habe einen Reverse-Proxy auf meinem apache 2.2.8 unter Ubuntu laufen.
Installiert ist auch das SSL Modul das soweit gut funktioniert.

Eingerichtet ist ein Zugriff von extern auf einen Microsoft Exchange Server 2003 der ebenfalls im SSL Modus läuft.

Wenn ich nun Zugriff auf den Exchange Server möchte soll ich mich 2x (Basic) authorisieren obwohl ich das (nicht wissentlich) so eingerichtet habe.
Die Zugriffsdaten für den ersten Login weiß ich natürlich nicht da ich dafür nirgends zugangsdaten hinterlegt habe. Wenn ich dann auf Abbrechen klicke kommt die eigentliche Basic Login des Exchanges in dem ich meine Zugangsdaten eingeben kann.
So funktioniert das aber nur im Firefox. Wenn ich im Exchange oder Chrome nach der ersten Authentisierung auf abbrechen klicke bekomme ich natürlich einen Zugang verweigert.

Das komische ist, das diese Verhalten nur beim Zugriff auf den Exchange passiert. Wenn ich die anderen Ziele (Trackserver/Cognos84) eingebe, will er keine (ungewollte) Basic Authentifizierung.
Wenn ich mich intern auf den Exchange verbinden möchte kommt auch nur die normale Basic Auth vom Exchange.

Vielen Dank im voraus

Gruß
Ben

Hier meine default-ssl config im Ordner "sites-available".

Code: Select all
<VirtualHost *:443>

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/ssl_access.log combined

        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
                Options Indexes MultiViews FollowSymLinks
                AllowOverride None
                Order deny,allow
                Deny from all
                Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>

        SSLEngine on
        SSLCertificateFile    /etc/apache2/ssl/server.crt
        SSLCertificateKeyFile /etc/apache2/ssl/server.key
        SSLCertificateChainFile /etc/apache2/ssl/ca.crt
        SSLCACertificateFile /etc/apache2/ssl/ca.crt


       <FilesMatch "\.(cgi|shtml|phtml|php)$">
                SSLOptions +StdEnvVars
        </FilesMatch>
        <Directory /usr/lib/cgi-bin>
                SSLOptions +StdEnvVars
        </Directory>

        BrowserMatch ".*MSIE.*" \
                nokeepalive ssl-unclean-shutdown \
                downgrade-1.0 force-response-1.0

        ProxyHTMLLogVerbose On
        ProxyRequests Off
        ProxyPreserveHost On
        ProxyHTMLExtended On
        SSLProxyEngine on
        RewriteLog "/var/log/apache2/rewrite.log"

        RewriteLogLevel 3

        RewriteEngine On
        RewriteMap percentsubject int:escape
        RewriteCond $1 ^/exchange/.*\%.*$
        RewriteRule (/exchange/.*) ${percentsubject:$1} [P]

        <Proxy *>
          Order deny,allow
          Allow from all
        </Proxy>

     
        ProxyPass               /bugzilla/                      http://trackserver/
        ProxyHTMLURLMap         http://trackserver/             /bugzilla/

        ProxyPass               /exchange/                      https://192.168.62.19/exchange/
        ProxyHTMLURLMap         https://192.168.62.19/exchange/ /exchange/

        ProxyPass               /public/                        https://192.168.62.19/public/
        ProxyHTMLURLMap         https://192.168.62.19/public/   /public/

        ProxyPass               /exchweb/                       https://192.168.62.19/exchweb/
        ProxyHTMLURLMap         https://192.168.62.19/exchweb/  /exchweb/

        ProxyPass               /misdemo/                       http://cognos84/misdemo/
        ProxyHTMLURLMap         http://cognos84/misdemo/        /misdemo/

</VirtualHost>
bemar
 
Posts: 6
Joined: 21. April 2009 11:34

Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests