Problem mit self.location

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit self.location

Postby x_s » 03. May 2010 19:12

Hallo zusammen,

eins vorweg, ich bin in Sachen apache ein absoluter noob, und stehe vor einem Problem für das ich keine Lösung finde:

Ich habe mir anhand eines Tutorials einen Apache2 mit virtuellen Hosts installiert. So weit ich das beurteilen kann, läuft alles einwandfrei. Ich habe allerdings ein Phenomen, das ich mir nicht erklären kann.

Ich möchte aus einer html Seite ein php script ausführen. Der Browser soll die html Seite aus der das Script aufgerufen wird auch nach dem Aufruf des Scripts weiterhin anzeigen.
Auf dem ersten von mir eingerichteten virtuellen Server funktioniert das auch, auf dem zweiten wechselt der Browser nach dem Click zum php script und zeigt damit eine leere Seite an.

Ich habe auf beiden virtuellen Servern die gleichen html und php Dateien kopiert. Die Konfigurationsdateien für die virtuellen Hosts habe ich verglichen, bis auf die Pfade zu den Serververzeichnissen sind sie identisch. Auch die Rechte sind in beiden Verzeichnissen gleich. Ich weiß einfach nicht wo ich noch ansetzen soll um den Fehler zu finden?!?!

Vielleich habt Ihr ja `ne Idee für mich.

Vielen Dank im Voraus...

Xenia

P.S. das Script wird folgender maßen aufgerufen:
onClick="self.location.href='ausfuehren.php?befehl= aus'"

Das Script sieht gekürzt wie folgt aus:
<?php
header('Status: 204 No Content');
$do = "echo ";
$do .= $_GET['befehl'];
shell_exec($do);
?>

Betriebssytem: Debian Lenny
Apache: 2.2.9 (Debian)
php: 5.2.6
x_s
 
Posts: 1
Joined: 03. May 2010 18:48

Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests