ProxyPreserveHost On funktioniert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

ProxyPreserveHost On funktioniert nicht

Postby jumeier » 03. April 2010 21:56

Hi,

Ich habe diese Directive von mod_proxy auf On gesetzt, da ich den ursprünglichen Remote-Host im Backend-Server benötige.
Leider bleibt sie aber ohne Effekt.

httpd hat Version 2.0.54. In httpd.conf habe ich konfiguriert:
Code: Select all
...
ProxyRequests Off
ProxyPreserveHost On
ProxyPass /content/sdt http://localhost:2222/content/sdt
ProxyPass /apps/sdt http://localhost:2222/apps/sdt
ProxyPassReverse /content/sdt http://localhost:2222/content/sdt
...


Wie gesagt erhalte ich nun auf dem Backend-Server immer 127.0.0.1, statt der ursprünglichen Adresse des Remote-Host.

Hat jemand ein Tipp?

Danke & Gruss,
Jürgen
jumeier
 
Posts: 3
Joined: 03. April 2010 21:31

Re: ProxyPreserveHost On funktioniert nicht

Postby Nobbie » 04. April 2010 12:43

jumeier wrote:Wie gesagt erhalte ich nun auf dem Backend-Server immer 127.0.0.1, statt der ursprünglichen Adresse des Remote-Host.


Das kling sehr danach, als wenn Du die Direktive ProxyPreserveHost nicht richtig verstanden hast. Diese bezieht sich NICHT auf IP-Adressen, sondern auf den Host Namen im HTTP Header (das ist üblicherweise der Domainname, keine IP).

Wie kommst Du zu dieser "Erkenntnis", wo "erhältst" Du den Wert 127.0.0.1?
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: ProxyPreserveHost On funktioniert nicht

Postby jumeier » 05. April 2010 01:08

Wie kommst Du zu dieser "Erkenntnis", wo "erhältst" Du den Wert 127.0.0.1?


Das ist natürlich richtig, dass der Domainname beim Backend-Server ankommt, also etwa mein_server.example.com und nicht 127.0.0.1 (Quelle: log-file Backend-Server).
Ich habe hier in diesem Post nur etwas abgekürzt. Denn das Problem bleibt das Gleiche, vorne kommt (gem. httpd access_log) ein 22.33.44.55 (und hier wirklich die IP-Nummer) rein, und hinten kriege ich den Domainnamen von meinem Host, obwohl die Directive ProxyPreserveHost gesetzt ist.

Erfahre gerne, in was ich mich hier täusche.

Gruss,
Juergen
jumeier
 
Posts: 3
Joined: 03. April 2010 21:31

Re: ProxyPreserveHost On funktioniert nicht

Postby Nobbie » 05. April 2010 10:58

jumeier wrote:Erfahre gerne, in was ich mich hier täusche.


Kann ich leider nicht beurteilen, da Deine Beschreibung immer noch verstümmelt ist bis zum Erbrechen und darüber hinaus. Was weiß ich denn, was Du im Logfile protokollierst?

Zudem bin ich mir immer noch sehr sicher, dass Du die Direktive falsch verstehst, denn eigentlich braucht man diese Einstellung so gut wie nie (ich wüßte auf Anhieb kaum Beispiele), denkbar wäre beispielsweise der Fall, dass Du auf dem RemoteProxy einen namebased virtuellen Host eingerichtet hast, der den gleichen Domainnamen trägt wie der erste Apache-Server. Damit könnte man den Request ggf. (ich habe es nicht probiert) auf diesen virtuellen Host weiterleiten, der aber auch nur auf diesem RemoteServer bekannt ist (hat dort eine andere IP als von außen).

Nicht zu Unrecht steht sinngemäß fast das gleiche bei der Dokumentation zu dieser Direktive, dass sie nur in (nicht genannten) Ausnahmefällen auf "On" stehen sollte.

Weiß Du wie ein HTTP Request aufgebaut ist und was diese Direktive genau tut?

jumeier wrote:Ich habe hier in diesem Post nur etwas abgekürzt. Denn das Problem bleibt das Gleiche, vorne kommt (gem. httpd access_log) ein 22.33.44.55 (und hier wirklich die IP-Nummer) rein, und hinten kriege ich den Domainnamen von meinem Host, obwohl die Directive ProxyPreserveHost gesetzt ist.


So wie Du es hier (sehr unsauber, deswegen verstehe ich es vielleicht auch genau falsch herum) beschreibst, wäre das genau die Wirkung dieser Direktive. Aber durch die uneindeutige Nennung von Domainnamen und Host (wo von wem und von was) kann ich es nicht 100% sagen. Du mußt erheblich besser beschreiben, wenn man Dir helfen soll.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: ProxyPreserveHost On funktioniert nicht

Postby jumeier » 06. April 2010 22:47

Hi Nobbie,

Selber halte ich Foren, bei denen jedes Mal noch irgendwelche unnötigen persönlichen Botschaften mitgeliefert werden, für hochgradig unprofessionell.

Das Bookmark für dieses Forum werden ich somit wohl rauslöschen können.
Wünsche dennoch keine allzu heftigen Auswürfe.

-- Jürgen
jumeier
 
Posts: 3
Joined: 03. April 2010 21:31


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests