Autoindex funktioniert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Autoindex funktioniert nicht

Postby 2bNs » 25. March 2010 20:38

Hallo allerseits,

ich möchte ein Unterverzeichnis (/htdocs/dl) für Dateidownloads nutzen. Ich möchte eine Autoindex-Seite für das Verzeichnis bekommen, wenn ich in der index.html auf den dazugehörigen Link klicke. Das funktioniert auch, wenn ich auf den Server per localhost zugreife, jedoch nicht aus dem Internet. Da bekomme ich eine Zeitüberschreitung. Woran kann das liegen?

mod_autoindex ist geladen

<Directory />
Options Indexes FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

<Directory /htdocs/dl>
Options Indexes FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

<a href="/dl">test</a>
2bNs
 
Posts: 3
Joined: 25. March 2010 20:32

Re: Autoindex funktioniert nicht

Postby Nobbie » 25. March 2010 20:55

Ist der Server überhaupt öffentlich via Internet erreichbar?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Autoindex funktioniert nicht

Postby 2bNs » 25. March 2010 21:25

ja, den Timeout bekomme ich nur, wenn ich auf den Link zum Unterverzeichnis klicke.

Sorry, war nicht so klar beschrieben.
2bNs
 
Posts: 3
Joined: 25. March 2010 20:32

Re: Autoindex funktioniert nicht

Postby Nobbie » 25. March 2010 22:10

>Deny from all

Und wozu darf überhaupt niemand zugreifen?

Die absoluten Pfade (/htdocs/dl) finde ich auch seltsam, ist das so installiert? So oder so ist Deine Beschreibung nach wie vor an Armseligkeit kaum zu toppen, nicht einmal das OS wird genannt, geschweige denn DocumentRoot o.ä. - es ist mehr als mühselig. Dabei suchst Du doch Hilfe, nicht wir.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Autoindex funktioniert nicht

Postby 2bNs » 25. March 2010 23:55

Ich wüsste auch nicht, warum das OS dafür wichtig ist?

Win 7 Pro, der Apache läuft unter nem eigenen User, der Leserechte auf htdocs und Unterordner besitzt. Pfade sind alle Standard. Es ging mal, geht neuerdings nicht mehr, obwohl ich an der Konfiguration nichts geändert habe.

DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs"

Ich hab die configs aus dem *backup*-Ordner wiederhergestellt, den einen Directory-eintrag erstellt (ohne gehts auch nicht), die Einträge für Ports und IPs geändert und das Antwortverhalten des Servers (Prod, Signature Off) geändert. Auch mit den Standard-Werten gehts nicht.

Das "Deny From All" ist standardmäßig in allen Directory-Einträgen der der httpd.conf gesetzt, daran wirds doch nicht liegen oder?

Der Apache läuft auf Port 8080. In meinem Router gibts einen Port Forward von extern Port 80 auf Port 8080 auf meinem Rechner. Das klappt auch wunderbar, nur dieser Unterordner halt nicht. Und das funktionierte wie gesagt schon mal mit dem gleichen relativen Pfad im Link.

Welche Informationen benötigt ihr noch?
2bNs
 
Posts: 3
Joined: 25. March 2010 20:32

Re: Autoindex funktioniert nicht

Postby Nobbie » 26. March 2010 00:12

2bNs wrote:DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs"


Wenn das der DocumentRoot ist, was soll der sinnlose Eintrag

<DIrectory "/htdocs/dl">

??

2bNs wrote:Das "Deny From All" ist standardmäßig in allen Directory-Einträgen der der httpd.conf gesetzt, daran wirds doch nicht liegen oder?


Weiß ich (noch) nicht - aber nach Deiner Meinung liegts ja auch nicht am Betriebssystem, zudem interessiert Dich die Installationsanleitung einen Dreck, die ausdrücklich empfiehlt, Xampp nicht nach C.\Program Files zu installieren, sondern nach c:\xampp.

Wenn Du sicher bist, dass es sowieso an nichts liegt - woran liegt es denn nach Deiner Meinung, wenn es an nichts liegt? Zudem habe ich (s.o.) auch das Gefühl, nur halbrichtige Fragmente hier zu sehen zu bekommen.

Es ist nervig, so zu helfen. Das macht mir keinen Spaß. Und Du unterschätzt maßlos die (Fehler)-Möglichkeiten, die allein die Windows-Installation an sich schon ermöglicht. Ich mache jetzt mal eine Pause, vielleicht weiß ja jemand anders was mit den Informationen anzufangen.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Autoindex funktioniert nicht

Postby Pitze » 27. March 2010 03:09

Das "Deny From All" ist standardmäßig in allen Directory-Einträgen der der httpd.conf gesetzt, daran wirds doch nicht liegen oder?

Nein ! Da dein DocumentRoot ja nicht auf das entsprechende Verzeichnis zeigt
So könnte es aussehen
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs">
Options -Indexes
AllowOverride None
Order allow,deny
Allow from all
</Directory>
Alias /dl "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/dl/"
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/dl">
Options +Indexes
AllowOverride None
Order allow,deny
Allow from all
</Directory>
DirectoryIndex index.php index.html index.htm
So und das ganze schön in einen Vhost verpackten
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests