FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Alles, was den Apache betrifft, kann hier besprochen werden.

FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby haegar » 04. December 2009 18:34

Hallo zusammen,

nach stundenlanger Suche im Forum mit zwar vielen Beiträgen zu ähnlichen Themen aber ohne Lösung für mein Problem poste ich nun doch mal meine Sorgen.

Ich habe auf einem V-Server von Strato Joomla laufen. Um die Suchmascheinenoptimierung zu nutzen, müsste ich mod_rewrite nutzen. Sobald ich aber über die .htaccess eine RewriteRule definiere, die auf den eigenen Server zeigt, bekomme ich nur einen 403-Error.

Forbidden
You don't have permission to access / on this server.
Apache/2.2.8 (Ubuntu) mod_python/3.3.1 Python/2.5.2 PHP/5.2.4-2ubuntu5.5 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g mod_perl/2.0.3 Perl/v5.8.8 Server at http://www.glodek-edv.de Port 80


Testweise habe ich eine ganz simple .htaccess erstellt
Code: Select all
RewriteEngine On
RewriteRule (.*) http://www.google.de


Die funktioniert!

Sobald ich aber die Original-htaccess von Joomla 1.5 nehme und dort die Engine aktiviere kommt der 403-Error.

zur Sicherheit (falls ich irgendwie eine falsche htaccess erwischt haben sollte) hier der Inhalt (alle Kommentare etc. rausgeworfen, dann ist übersichtlicher):
Code: Select all
Options +FollowSymLinks
RewriteEngine On

# RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]


Probeweise habe ich auch mal alle Zeilen bis auf RewriteEngine On und die beiden letzten Zeilen (die mit den RewriteRules) auskommentiert, also so:
Code: Select all
RewriteEngine On
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]


-> gleiches Ergebnis, 403-Error

Da die einfache Umleitung zu Google funktioniert, muss es irgendetwas in der .htaccess sein, aber was??

Im Apache-Fehler-Log steht:
Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/glodek-edv.de/httpdocs/index.php


Das wird aber doch in der .htacces mit
Options +FollowSymLinks eingeschaltet ???

Auch der Tipp, in der apache-konfiguration den DirectoryIndex anzupassen (und Apache neu starten) hat nichts gebracht
Also so:
DirectoryIndex index.html index.cgi index.php index.pl index.xhtml
und nicht so:
DirectoryIndex index.html index.cgi index.pl index.php index.xhtml


Server ist ein STRATO V-Server mit Ubuntu 8.04.

...und hier noch die relevante Apatche-Konfiguration mit den vorgegebenen FollowSymLinks-Einträgen. Das sieht doch eigentlich auch so aus, als wäre alles OK, denn FollowSymLinks ist dort ja eingeschaltet. Probeweise habe ich mal auf AllowOverride All umgestellt. Daruafhin kam dann ein PageNotFound, was zumindest beweist, dass ich die richtige Conf erwischt habe :wink:

Code: Select all
NameVirtualHost *
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


So, an dieser Stelle haben mich dann meine Kenntnisse endgültig verlassen. Wenn in der apache-Konfiguration "Options FollowSymLinks" steht, warum erscheint dann im errorlog "Option FollowSymLinks or SymLinksIfOwnerMatch is off"

In der Hoffnung auf kompetente Hilfe,
Euer verzweifelter Hägar
Last edited by haegar on 04. December 2009 21:53, edited 2 times in total.
haegar
 
Posts: 7
Joined: 04. December 2009 18:14
XAMPP version: 5.6.24
Operating System: Windows 10

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Nobbie » 04. December 2009 21:37

Ich sehe überhaupt nicht, was das mit FollowSymLink zu tun haben soll. ich sehe nicht einmal irgendeine Weiterleitung. Das einzige, was ich sehe, ist ein Umschreiben des Requests auf die Datei index.php, wobei Du nicht einmal angibst, was Du eigentlich im Browser eingibst (das wäre das MInimum, was wir wissen müssen).

Falls also irgendwas eingegeben wird, was ein Umschreiben auf index.php bewirkt, ist die Frage, gibt es diese index.php, wenn ja, welche Rechte hat sie, was steht drin usw.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby haegar » 04. December 2009 22:16

Hallo Nobbie,

mit FollowSymLinks hat es insofern zu tun, als das die einzige Fehlermeldung ist, die in der error.log des Apache auftaucht. Außerdem steht da ja explizit drin (habe eben noch mal die komplette Meldung im Zitat gepostet), dass wegen des fehlenden FollowSymLinks die RewriteRule auf die index.php vom Server nicht akzeptiert wird.
Hier nochmals die vollständige Fehlermeldung aus dem Errorlog
Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/glodek-edv.de/httpdocs/index.php


Die Index.php ist die von Joomla 1.5, was auch ohne .htaccess einwandfrei funktioniert. Insofern gehe ich davon aus, dass die index.php auch OK ist.
Aufgerufen wird eigentlich auch direkt die index.php, wenn ich http://www.glodek-edv.de im Browser eingebe. Das macht soweit ich es verstanden habe der apache über die DirectoryIndex-Angabe automatisch, indem er im aufgerufenen Verzeichnis eine index.pl, index.php oder index.htm sucht und wenn gefunden ausführt.

Ich kenne mich mit RewriteRules leider nicht aus und weiß daher auch nicht genau, was die in der .htaccess bewirken sollen - habe das so aus dem Joomla-Standard für die Verwendung von mod_rewrite mit Joomla übernommen. Das Problem ist aber doch die laut Fehlerlog nicht eingeschaltete Option FollowSymLinks.

Gruß,
Siegbert
haegar
 
Posts: 7
Joined: 04. December 2009 18:14
XAMPP version: 5.6.24
Operating System: Windows 10

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Nobbie » 04. December 2009 23:25

Ich kann nur vermuten, dass die index.php oder irgendein Ordner darüber ein symbolischer Link auf eine andere Datei (oder anderen Ordner) ist. Entweder hast Du selbst das so eingerichtet, oder ist von Strato so vorgegeben worden.

Da es Dein eigener Server ist, schalte eben Followsymlink ein, dann wird Fehlermeldung wohl verschwinden.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Pitze » 05. December 2009 04:07

AllowOverride None

Schau mal so lange das so aussieht kanst du so viele .htaccess datein da hin packen wie du willst der Server wird sie IGNORIEREN. Also noch mal schnell die Apache Docu und nachlesen. :wink:
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby haegar » 05. December 2009 12:47

Hallo Pitze,

das ist es ja was ich nicht verstehe. In der Apache-Konfiguration steht ja drin, dass die Option FollowSymLinks EINGESCHALTET ist. Das "AllowOverride None" sollte mir also verbieten, sie abzuschalten oder andere Optionen zu aktivieren, was ja OK wäre.:
Code: Select all
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
               Options Indexes FollowSymLinks MultiViews
                AllowOverride None

Obwohl die Option also eigentlich AN ist, kommt die Fehlermeldung, dass sie angeblich OFF sei :?

Da der V_Server mit Ubuntu 8.04 arbeitet, müsste der Ort der Konfiguration mit /etc/apache2/sites-enabled/000-default eigentlich auch passen.

Gibt es evtl. eine Möglichkeit, mit einem PHP-Programm analog zu phpinfo() die Konfiguration des Apache abzufragen? Vielleicht ergibt das ja einen Hinweis.
haegar
 
Posts: 7
Joined: 04. December 2009 18:14
XAMPP version: 5.6.24
Operating System: Windows 10

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Wiedmann » 05. December 2009 13:07

Das "AllowOverride None" sollte mir also verbieten, sie abzuschalten oder andere Optionen zu aktivieren, was ja OK wäre.:

Naja, ein "AllowOverride None" schaltet ".htaccess" Dateien komplett ab. Wenn dieses aktiv wäre, dann würde überhaupt keine Meldung bezgl. RewriteRule oder "Options FollowSymLinks" kommen.

Der Apache benutzen die Configdatei, oder den VHost, die/den du gepostest hast nicht (oder überschreibt die Werte an einer anderen Stelle wieder.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby haegar » 05. December 2009 13:14

Der Apache benutzen die Configdatei, oder den VHost, die/den du gepostest hast nicht (oder überschreibt die Werte an einer anderen Stelle wieder.)

Kann ich denn irgendwie herausfinden, wo die eigentliche Konfiguration erfolgt?
haegar
 
Posts: 7
Joined: 04. December 2009 18:14
XAMPP version: 5.6.24
Operating System: Windows 10

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Wiedmann » 05. December 2009 13:28

Kann ich denn irgendwie herausfinden, wo die eigentliche Konfiguration erfolgt?

Wenn du nicht grad was wie Confixx auf dem Server lauf hast, könnte man in der Shell dieses machen:
Code: Select all
httpd -V | grep "SERVER_CONFIG_FILE"

Ansonsten kann man mit "ps" nachschauen, ob der Server evtl. mit dem "-f ..." Parameter gestartet wurde. Dann wäre dieses die Hauptconfigdatei.

Und in dieser Configdatei muss man dann halt schauen, wass alles (und wie) includiert wird.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby Pitze » 05. December 2009 21:08

Ups!Stimmt hat Wiedmann recht hab ich gar nicht gesehen letzte Nacht, fehlt der "ServerName" also wird der Server wohl die httpd.conf benutzen da er den vhost nicht zuordnen kann.
ServerSignature On

Das als Tip ist immer Off die Auflistung was du alles Instaliert hast hilft den Strolchen die deinen Server wollen dir aber nicht wirklich
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: FollowSymLinks ist eingeschaltet, wird aber nicht erkannt

Postby haegar » 08. January 2010 21:58

Hallo zusammen,

habe das Problem nun doch selbst lösen können (na ja, fast...)

Eigentliches Problem war PLESK 9.01. Hier gab es ein Problem mit der korrekten Verwaltung der Option FollowSymLinks. Nach einem Update auf 9.2 lief das.

Aber:
- seitdem habe ich Probleme mit der safe_mode-Einstellung
- um diese über PLESK ausschalten zu können muss ich APACHE als Modul ausführen statt FastCGI
- dadurch kommt es zu weiteren Berechtigungsproblemen (dazu gibt es etliche Postings mit dem Stichwort "wwwrun-Problem")

Aber das ist ein anderes Thema und gehört nicht in diesen Thread.

Bis mal wieder...
Haegar
haegar
 
Posts: 7
Joined: 04. December 2009 18:14
XAMPP version: 5.6.24
Operating System: Windows 10


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests