Installation of Apache 2.2 and PHP 5.2 problems

Alles, was den Apache betrifft, kann hier besprochen werden.

Installation of Apache 2.2 and PHP 5.2 problems

Postby BIJU » 06. November 2009 12:04

Hi,
I am very new in PHP. I am working on Windows XP sp2 plateform and I installed Apache 2.2 in my system. It worked good bcose when I browsed http://127.0.0.1/, It gave such a message initially.
Thereafter I edited the Apache's htdocs file and added DocumentRoot as DocumentRoot "C:/PHP3"

For installing PHP, I made the following changes ;-
(I unzipped PHP's installion files in C:\PHP" folder)

1) C:\php\php.ini-dist it to php.ini
2) edit the doc_root = "C:\php3"
3) Edit error reporting into error_reporting = E_ALL | E_NOTICE | E_STRICT
4)Editing Apache Conf File and added the follwing code at the very begining.
LoadModule php5_module "C:/php/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php"

and also made
<IfModule dir_module>
DirectoryIndex index.php index.html default.html
</IfModule>

After that when I tested by creating a sample php file in C:\PHP3 folder, I got error message in my IE as "The website declined to show this webpage"
Now when I am browsing my localhost, I am getting the same error message.
I don't know where error happended . If any body knows what is the problem, could pls help me and thanks in advance

Regards,
BIJU
BIJU
 
Posts: 1
Joined: 06. November 2009 11:47

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests