Kann nicht auf Unterverzeichnisse zugreifen

Alles, was den Apache betrifft, kann hier besprochen werden.

Kann nicht auf Unterverzeichnisse zugreifen

Postby webdesignteam » 31. December 2003 00:46

Hallo,

folgendes Problem:

Beispiel Domain: test.dyndns.org
Beispiel IP: 222.222.222.222

wenn ich meinen Apache Server über z.B. test.dyndns.rog anspreche oder über die aktuelle IP, öffnet sich der hinterlegte index.html File.

Soweit so gut.

Wie kann ich allerdings auf ein Unterverzeichniss zugreifen? z.B.

http://222.222.222.222/docs2/index.html

Es kommt immer die Meldung:

404 die Seite wurde nicht gefunden.

Hoffe auf Hilfe!

Gruß webdesignteam
webdesignteam
 
Posts: 2
Joined: 31. December 2003 00:38

Re: Kann nicht auf Unterverzeichnisse zugreifen

Postby Manni » 31. December 2003 07:51

webdesignteam wrote:wenn ich meinen Apache Server über z.B. test.dyndns.rog anspreche oder über die aktuelle IP, öffnet sich der hinterlegte index.html File.


Ich nehme an, dieses index liegt im Ordner den Du für htdocs deklariert hast.

webdesignteam wrote:Wie kann ich allerdings auf ein Unterverzeichniss zugreifen? z.B.
http://222.222.222.222/docs2/index.html


Hast Du dieses Unterverzeichniss unterhalb von htdocs gemacht, oder ausserhalb? Anderst kann ich mir das nicht erklären.

Gruß
happy new year
User avatar
Manni
 
Posts: 31
Joined: 19. July 2003 22:09

Postby webdesignteam » 31. December 2003 09:44

Hab mal versucht von einem externen Rechner zuzugreifen - klappt einwandfrei. Jetzt stellt sich die Frage wie kann ich von dem Rechner auf dem der Server läuft auf diesen zugreifen? Unter Verwendung der Internen IP (192.168.0.2) klappt das einwandfrei - auch mit Unterverzeichnissen, wenn ich allerdings die von t-online zugeteilte Adresse eingebe erscheint immer das Router-Login-Fenster.

Gruß webdesignteam
webdesignteam
 
Posts: 2
Joined: 31. December 2003 00:38

Postby Manni » 04. January 2004 04:32

Das ist dann anscheinend ein Routerpoblem, aber von denen weis ich leider nichts. Vielleicht probierst Du mal http://deine_ip:80. Bei Routern muss man doch immer irgend welche Ports forwarden, deshalb die :80

Gruß
User avatar
Manni
 
Posts: 31
Joined: 19. July 2003 22:09

Postby Kristian Marcroft » 04. January 2004 11:59

Hi,

von hinter einem Router übers Inet an die eigene Inet Ip geht nicht...
Routing Technisch garnicht möglich!
Warum? KA
So sind halt nunmal die Routingstandards....
Sprich von intern wirst du deine LAN IP verwenden müssen.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Kristian Marcroft » 04. January 2004 12:43

Hi,

da die FRage jetzt immer häufiger kommt, hier mal ein FAQ Beitrag:

http://faq.kwm-web.info/index.php?sid=1 ... 77&lang=de

Bitte lest diesen...
Einiege Router mögen es nun können...
Andere nicht...
Dennoch ist es kein Standard, und Support dafür kann hier auch keiner geben.
Die wahrscheinliuchkeit das hier jemand den gleichen Router mit den gleichen Einstellungen hat ist sehr gering...

Also fragt dann lieber bei eurem Router Hersteller nach...
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests