AJP, Tomcat und LifeRay

Alles, was den Apache betrifft, kann hier besprochen werden.

AJP, Tomcat und LifeRay

Postby TomRiddley » 16. September 2009 14:03

Hallo Community,

ich hoffe auf diesem Wege endlich eine Lösung für mein Problem zu finden.
Ich habe ein Liferay-Portal auf einem Webserver unserer Firma laufen. Die Konstellation, soweit ich sie überschaue, ist ein Tomcat mit vorgeschaltetem Apache-Server.

Der Apache dient zum Verwalten von zwei Domains über die auf das Liferay-System zugegriffen werden kann. Des Weiteren wurde die Verbindung zwischen dem Apache und dem Tomcat mittels mod_proxy_ajp realisiert. Das System läuft, die Benutzer können auf das Portal zugreifen.

Das Problem taucht nach einer gewissen Laufzeit auf. Das Portal ist dann nicht ansprechbar bzw. kann nicht erreicht werden. Einzige Konfliktlösung zur Zeit ist, den Apache neu zu starten. Danach funktioniert alles wieder eine gewisse Zeit lang. Im Error.log des Apache finden sich folgende Einträge (kurzer Abgriff vor dem manuellen Neustart):
[Wed Sep 16 13:27:42 2009] [error] (OS 10060)A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. : ajp_ilink_receive() can't receive header
[Wed Sep 16 13:27:42 2009] [error] ajp_read_header: ajp_ilink_receive failed
[Wed Sep 16 13:27:42 2009] [error] (120006)APR does not understand this error code: proxy: read response failed from <HOSTIP_entfernt>:8009 (<HOSTIP_entfernt>)

Diese Einträge sind immer wieder im Log verzeichnet.

Liferay und der Apache laufen übrigens auf folgendem System:

  • Windows Server 2003 mit SP1
  • Intel Pentium D 2,8 GHz
  • 4 GB RAM

Habt ihr eine Idee, woran das liegen kann? Benötigt ihr noch weitere Informationen? Wer kann helfen?

Besten Dank
Tom
TomRiddley
 
Posts: 1
Joined: 16. September 2009 12:52

Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests