sessionmanagement

Alles, was den Apache betrifft, kann hier besprochen werden.

sessionmanagement

Postby th1alb » 10. September 2009 14:32

Hi zusammen,

ich werde fast verrückt....

Ich habe eine Webanwendung an der sich Benutzer vorher anmelden müssen.
Dazu werden sessions eingesetzt.

Das mach ich wie folgt:
Code: Select all
   ini_set("session.use_trans_sid", "0");
   ini_set("session.gc_probability", "1"); // Session garbage control de-/aktivieren
   //ini_set("allow_call_time_pass_reference", "1");
   ini_set("memory_limit", "512M");

   // Session starten
   session_name("sid");
   session_set_cookie_params(3600);
   session_start();
   
   // write to session variable to prevent it from timing out
   $_SESSION['last_access'] = time();

........


Soweit funktioniert das auch. Ich kann in dem Interface arbeiten etc.
Leider ist es so, das nach unbestimmter Zeit plötzlich wieder die Anmeldeseite kommt,
dabei hat sich der user nicht ausgeloggt oder ähnliches gemacht. Auch ein Sessiontimeout ist
nicht eingetreten..

Man muss sich dann erneut anmelden.

Ich habe jetzt wirklich schon viel versucht...es werden aber auch kein fehler in php geworfen...

Wie kann ich das verhalten debuggen oder hat jemand vllt. auch schon so ein Problem gehabt?
Liegt das eurer Meinung nach am Apache oder an PHP bzw. meinem Script?

Viele Grüße
th1alb
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: sessionmanagement

Postby Nobbie » 10. September 2009 16:30

Code: Select all
session_set_cookie_params(3600);


Dabei wird genau hier eine Stunde Lifetime gesetzt. Danach ist das Sessioncookie platt. Wieso machst Du das, wenn Du das nicht willst?
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: sessionmanagement

Postby th1alb » 10. September 2009 16:49

Nobbie wrote:
Code: Select all
session_set_cookie_params(3600);


Dabei wird genau hier eine Stunde Lifetime gesetzt. Danach ist das Sessioncookie platt. Wieso machst Du das, wenn Du das nicht willst?



ja, das ist mir klar...leider beendet sich die session manchmal schon nach 5 minuten...
aber ich kommentiere es trotzdem mal aus...


EDIT:
SCHEINBAR lag es wirklich daran...danke für den Hinweis :)
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests