Problem mit Installation unter HPUX11

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit Installation unter HPUX11

Postby coredump » 22. December 2003 12:36

Hallo!

Hoffentlich kennt sich jemand mit HP Unix 11 aus :wink:

Ich versuche Apache 2.0 unter HP-UX 11 zu installieren. Die Konfiguration hat geklappt "./configure --prefix=/opt/apache", das anschliessende "make" auch. "make install" hingegen bricht ab:
Code: Select all
 
(cd /opt/apache/lib && rm -f libexpat.sl.1 && ln -s libexpat.sl.1.0 libexpat.sl.1)
(cd /opt/apache/lib && rm -f libexpat.sl && ln -s libexpat.sl.1.0 libexpat.sl)
chmod 555 /opt/apache/lib/libexpat.sl.1.0
chmod: can't access /opt/apache/lib/libexpat.sl.1.0


Zuvor erscheint noch eine Fehlermeldung aber das Installationsscipt bricht dabei nicht ab:
Code: Select all
 
cp killbatch /opt/batch
cp: cannot access killbatch: No such file or directory
/opt/batch/killbatch not found
cp ../init.d_batchd /etc/init.d/batchd
cp:/etc/init.d/: No such file or directory
/etc/init.d/batchd not found


Ich kenne mich Unix leider nicht sehr gut, ich habe nicht mal eine Idee woran es liegen könnte. Bin für jeden Tip dankbar!

Gruß
coredump
 
Posts: 3
Joined: 22. December 2003 12:30

Postby Kristian Marcroft » 22. December 2003 14:46

Hi,

unter welchem User machst du das "make install" ??
Sollte "root" sein...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby coredump » 22. December 2003 14:54

Ja, unter root....
coredump
 
Posts: 3
Joined: 22. December 2003 12:30

Postby Kristian Marcroft » 22. December 2003 15:34

Hi,

1. machst mal bitte ein
updatedb
dann
locate libexpat.sl.1.0
und dann
locate killbatch

Bitte jeweils die Ausgabe hier pasten.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby coredump » 22. December 2003 15:57

Die Kommandos updatedb und locate gibts auf dem Betriebssystem nicht. Ich habs mal durch find . -name libexpat.sl.1.0 und killbatch ersetzt. Sollte das gleiche sein, oder?

Ausgabe:
./home/mike/http/httpd-2.0.48/srclib/apr-util/xml/expat/lib/.libs/libexpat.sl.1.0
("./home/mike/http/httpd-2.0.48/" ist das Source-Installationsverzeichnis)

killbatch findet er nicht.....
coredump
 
Posts: 3
Joined: 22. December 2003 12:30


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests