Apache im WindowsCluster

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache im WindowsCluster

Postby KCLAAS » 19. August 2009 14:28

Ich habe bisher das komplette XAMPP-Paket unter XP genutzt. Nun soll es unter Microsoft Windows Server 2008 Enterprise im Windows Failover-Cluster laufen.
Jetzt habe ich folgendes Problem. Ich kann den Apache normal über das XAMPP-Control-Panel starten, ich kann den Dienst stoppen und starten, wenn ich den Dienst aber im Cluster konfiguriere und online schalte, geht er in einen Fehler.
Clustermeldungen
Bei der Clusterressource "Apache2.2" im geclusterten Dienst oder in der geclusterten Anwendung "BIGREDCL" ein Fehler aufgetreten.
Beim allgemeinen Dienst "Apache2.2" ist der Fehler "1" aufgetreten. Prüfen Sie das Anwendungsereignisprotokoll.

im Anwendungsereignisprotokoll kommen massig Meldungen der Art
The Apache service named reported the following error:
>>> Usage: L:\\xampp\\apache\\bin\\httpd.exe [-D name] [-d directory] [-f file] .
The Apache service named reported the following error:
>>> [-C "directive"] [-c "directive"] .
The Apache service named reported the following error:
>>> -t : run syntax check for config files .

Kennt jemand das Problem?

Gruß Karsten

Gruß Karsten
KCLAAS
 
Posts: 2
Joined: 19. August 2009 13:57

Re: Apache im WindowsCluster

Postby KCLAAS » 19. August 2009 14:36

Danke Problem gelöst:
mit regedit die clusterresource gesucht und StartupParameters
geändert von
" -k runservice"
auf
""

und schon läufts

Karsten
KCLAAS
 
Posts: 2
Joined: 19. August 2009 13:57


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests