RewriteCond greift nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

RewriteCond greift nicht

Postby Hagbard-Celine » 05. August 2009 09:17

Moin Leute,

habe gerade ein Problem mit einer RewriteCond die nicht greift.
Also folgendes soll per .htacces ModRewrite gelöst werden:

Alle Anfragen auf www.domain-a.de sollen auf www.domain-b.de umgeleitet werden,
einzige Ausnahme ist www.domain-a.de/admin, da soll keine Umleitung stattfinden.

Folgende Möglichkeiten habe ich per .htaccess Datei schon probiert,
leider wird bei beiden immer jede Anfrage weitergeleitet.

Möglichkeit 1)
-----------------------------------
RewriteEngine on
RewriteRule !/admin http://www.domain-b.de [R]

Möglichkeit 2)
----------------------------------
RewriteEngine on
RewriteCond %{REQUEST_URI} !^/admin
RewriteRule ^.* http://www.domain-b.de/ [R]


Leider habe ich keine Idee was an der Formulierung fehlerhaft ist.
Danke euch schon mal im voraus :)
Hagbard-Celine
 
Posts: 10
Joined: 21. August 2007 19:39

Re: RewriteCond greift nicht

Postby Nobbie » 05. August 2009 12:49

Der Slash ist zu viel, stattdessen muss mit ^ sichergestellt werden, dass admin am Anfang steht (sonst wird beispielsweise auch www.domain-a.de/xxxx/admin nicht weitergeleitet):

RewriteEngine On
RewriteRule !^admin http://www.domain-b.de [R]
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: RewriteCond greift nicht

Postby Hagbard-Celine » 05. August 2009 14:23

Hey,

ich hab das Problem vorhin "fixen" können, meine alte Regel (Methode1) hätte im Prinzip auch funktioniert aber ich depp habe vergessen das, wenn man nicht eingeloggt ist, man automatisch wieder ein Verzeichnis höher geworfen wird...und man somit wieder umgeleitet wurde.

Oh man sorry und vielen Dank für die Hilfe :(
Hagbard-Celine
 
Posts: 10
Joined: 21. August 2007 19:39


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests