mod_headers will nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_headers will nicht

Postby Urknall » 19. July 2009 20:17

Hi,
wir haben nun einen eigenen Server mit Apache 2.2 (1und1 V-Server)
Ich versuche vergeblich das Modul
mod_headers
einzubinden.

Ich kenne mich leider in Linux nicht aus, und wäre dankbar wenn mir jemand sagen könnte, warum das Modul nicht geladen wird.
Code: Select all
LoadModule headers_module /usr/lib64/apache2-prefork/mod_headers.so

Hab ich in die vhost.conf geschrieben, aber wenn ich mir über
Code: Select all
<?php
print_r(apache_get_modules());
?>

Die laufenden Module anzeigen lasse ist es nicht mit dabei.

Bin Dankbar für jede Hilfe.
Urknall
 
Posts: 4
Joined: 19. July 2009 20:10

Re: mod_headers will nicht

Postby Urknall » 22. July 2009 09:33

Hey, kann mir den keiner hier sagen, wie ich das Modul geladen bekomme?
Urknall
 
Posts: 4
Joined: 19. July 2009 20:10

Re: mod_headers will nicht

Postby Xardas der Dunkle » 22. July 2009 09:41

Klingt doof, aber hast du den Apache auch neu gestartet?

wir haben nun einen eigenen Server mit Apache 2.2 (1und1 V-Server)

Betriebssystem?
Je nach Betriebssystem kann das neustarten nämlich anders laufen.

Meistens ist es aber sowas:
Code: Select all
/etc/init.d/apache2 reload


Falls du doch Xampp einsetzen solltest, was ich aber auf Grund der 64bit Lib nicht annehme:
Code: Select all
/opt/lampp/lampp restart
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: mod_headers will nicht

Postby Urknall » 22. July 2009 09:49

Wir haben Suse 10.x müsst jetzt nachsehen.
Es läuft auch Pleskt und Virtuozo.

Hab nicht nur den Apache mit versch. konstellationen neugestartet sondern auch den ganzen Server.

Er läd dieses Modul aber einfach nicht.

Ich habs in verschiedene conf Dateien geschrieben, der Ordner des Moduls ist auch vorhanden.

Deswegen ja die Frage, ob ich da was falsch geschrieben habe, oder was ich da falsch mache.
Den mehr als das konnte ich aus den ganzen Hilfen und infos in den Kommentaren der CONF-Dateien steht nicht rauslesen.
Urknall
 
Posts: 4
Joined: 19. July 2009 20:10

Re: mod_headers will nicht

Postby Xardas der Dunkle » 22. July 2009 09:57

Plesk

Wird der Server normalerweise über Plesk vergewaltigt (verwaltet kann man da eig. gar nicht sagen :mrgreen:)?
Kannst du das Modul nicht über Plesk aktivieren? Bei Plesk weiß man nämlich nie, wo die Konfigurationsdateien wirklich liegen ...

Ich weiß jetzt auch nicht wie unter SuSe die Struktur des /etc/apache2-Verzeichnisses ist. Wir haben zwar in der Schule SuSe verwendet, aber seit dem benutze ich selber nur noch Debian.
Könntest du vllt mal die Ausgabe von:
Code: Select all
ls -l /etc/apache2

posten?

mfG
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: mod_headers will nicht

Postby Urknall » 22. July 2009 10:22

Aber na klar

:~ # ls -l /etc/apache2

total 136
-rw-r--r-- 1 root root 1764 Mar 26 2008 charset.conv
drwxr-xr-x 2 root root 4096 Jul 5 01:51 conf.d
-rw-r--r-- 1 root root 3763 Mar 26 2008 default-server.conf
-rw-r--r-- 1 root root 2765 Mar 26 2008 errors.conf
-rw-r--r-- 1 root root 8505 Jun 19 23:31 httpd.conf
-r-------- 1 root root 2954 Jun 19 23:30 httpd.pem
-rw-r--r-- 1 root root 1053 Jun 19 23:31 listen.conf
-rw-r--r-- 1 root root 12958 Mar 26 2008 magic
lrwxrwxrwx 1 root root 13 Nov 1 2008 mime.types -> ../mime.types
-rw-r--r-- 1 root root 1503 Mar 26 2008 mod_autoindex-defaults.conf
-rw-r--r-- 1 root root 369 Mar 26 2008 mod_info.conf
-rw-r--r-- 1 root root 1057 Mar 26 2008 mod_log_config.conf
-rw-r--r-- 1 root root 5107 Jun 19 23:31 mod_mime-defaults.conf
-rw-r--r-- 1 root root 763 Sep 22 2007 mod_perl-startup.pl
-rw-r--r-- 1 root root 334 Mar 26 2008 mod_status.conf
-rw-r--r-- 1 root root 1255 Mar 26 2008 mod_userdir.conf
-rw-r--r-- 1 root root 85 Mar 26 2008 mod_usertrack.conf
-rw-r--r-- 1 root root 4573 Nov 1 2008 server-tuning.conf
-rw-r--r-- 1 root root 2957 Mar 26 2008 ssl-global.conf
drwxr-xr-x 2 root root 4096 Nov 1 2008 ssl.crl
drwxr-xr-x 2 root root 4096 Nov 1 2008 ssl.crt
drwxr-xr-x 2 root root 4096 Nov 1 2008 ssl.csr
drwx------ 2 root root 4096 Nov 1 2008 ssl.key
drwxr-xr-x 2 root root 4096 Nov 1 2008 ssl.prm
drwxr-xr-x 2 root root 4096 Jun 19 23:21 sysconfig.d
-rw-r--r-- 1 root root 22 Mar 26 2008 uid.conf
drwxr-xr-x 2 root root 4096 Nov 1 2008 vhosts.d
-rw-r--r-- 1 root root 93 Jun 19 23:31 workers.properties
Urknall
 
Posts: 4
Joined: 19. July 2009 20:10

Re: mod_headers will nicht

Postby Xardas der Dunkle » 22. July 2009 10:55

Hast du den Eintrag schon einmal direkt in der httpd.conf gemacht?
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests

cron