SVN mit Apache

Alles, was den Apache betrifft, kann hier besprochen werden.

SVN mit Apache

Postby skaiser » 02. July 2009 21:50

Sehr geehrte Damen und Herren,

wie im Betreff zu lesen ist, geht es hier um die Einrichtung eines SVN Servers über Apache.

Nachdem ich SVN installiert, und ein Repos-Verzeichnis angelegt habe, nahm ich folgende änderungen in der http.conf des Apache webservers vor:


Folgende Zeile wurde bei den Modulen hinzugefügt:
Code: Select all
LoadModule dav_svn_module modules/mod_dav_svn.so


des weiteren wurde folgender Abschnitt am ende der .conf-Datein eingefügt:

Code: Select all
<Location /svn/myrepos
DAV svn
SVNPath S:\SVN Server\SVNTESTDir\myrepos
</Location>


Ausserdem wurden Folgende Module in das /modules-Verzeichnis des Apache Kopiert:
Code: Select all
mod_authz_svn.so
mod_dav_svn.so


Nachdem die änderungen gespeichert wurden, ließ sich der Apache nicht mehr hochfahren, worauf ich den Anhang mit der Location auskommentierte.


Daraufhin ließ sich Apache zwar starten, führ jedoch gleich wieder herunter.
Nachdem "LoadModule dav_svn_module modules/mod_dav_svn.so" ebenfalls auskommentiert wurde lief Apache wieder normal.

Meine Frage ist nun, wie ich Apache Konfigurieren kann, das mein Vorhaben klappt.

Ich habe die Xampp version 1.7 und die Version 1.6.3 von SVN installiert.
Ausserdem hab ih mich dach der Anleitung von http://www.html-world.de/program/svn_1.php gerichtet.
Als Betriebsystem dient Windows XP Pro mit Kaspersky als Firewall.

Schon einmal vielen dank im vorraus und einen schönen Abend noch.
Last edited by skaiser on 02. July 2009 21:54, edited 2 times in total.
skaiser
 
Posts: 9
Joined: 28. April 2009 09:06

Re: SVN mit Apache

Postby Wiedmann » 02. July 2009 21:52

Ausserdem wurden Folgende Module in das /bin-Verzeichnis des Apache Kopiert:

Module gehören ins "/modules" Verzeichnis.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: SVN mit Apache

Postby skaiser » 02. July 2009 21:55

Mir ist beim Schreiben des Beitrages ein kleiner Fehler unterlaufen, wodurch ich statt des /modules das /bin- Verzeichnis angegeben habe.. Die Daten wurden Ortnungsgemäß ins /modules Verzeichnis Kopiert.

Habs verbessert.
skaiser
 
Posts: 9
Joined: 28. April 2009 09:06

Re: SVN mit Apache

Postby Wiedmann » 02. July 2009 22:08

Die Daten wurden Ortnungsgemäß ins /modules Verzeichnis Kopiert.

Nichts desto trotz kommen glaub auch noch in's /bin Verzeichnis 2 Dateien (intl3_svn.dll und libdbxx.dll).

Folgende Zeile wurde bei den Modulen hinzugefügt:

Die anderen DAV-Module hast auch geladen (mod_dav, mod_dav_fs, mod_authz_svn)?

Ansonsten:
Nachdem die änderungen gespeichert wurden, ließ sich der Apache nicht mehr hochfahren,

Welche Fehlermeldung gibt der Apache aus?

Ich habe die Xampp version 1.7 und die Version 1.6.3 von SVN installiert.

Das bedeutet was genau?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: SVN mit Apache

Postby skaiser » 03. July 2009 06:42

Habe die beiden Dateien intl3_svn.dll und libdb44.dll ins Bin verzeichnis vom Apqche Kopiert.

Die drei Module sind Ebenfalls geladen.

Fehlermeldungen bekomme ich Vom Controlpanel keine.
Beim manuellen start jedoch folgende:

Code: Select all
Syntax error on Line 532 of S:/SVN Server/Apache/xampp/apache/conf/httpd.conf:
SVNPath takes one arguement, specifies the Location in the filesystem for a Subversion repositorys files.



Hierzu ist zu sagen, das besagtes Verzeichnis bereits angelegt wurde und der Pfad korrekt ist.

Hier noch mal der betroffene Abschitt in der httpd.conf:

Code: Select all
<Location /svn/myrepos>
DAV svn
SVNPath S:\SVN Server\SVNTESTDir\myrepos
</Location>



Habe testweise mal den Locationteil auskommentiert und getestet.

Seitens der Module und .dll dateien funktioniert Apache.
skaiser
 
Posts: 9
Joined: 28. April 2009 09:06

Re: SVN mit Apache

Postby Xardas der Dunkle » 03. July 2009 06:58

In deinem Pfad befindet sich ein Leerzeichen, darum musst du den Pfad in Anführungszeichen schreiben:
Code: Select all
<Location /svn/myrepos>
     DAV svn
     SVNPath "S:\SVN Server\SVNTESTDir\myrepos"
</Location>

Es ist eh immer besser keine Leerzeichen in Pfaden zu haben unter denen Server-Systeme lauschen :p.

Btw. ist es beabsichtigt das du jetzt jedes Repos einzeln nach /svn/{INSERT-NAME-HERE} verdrahtest?
Ansonsten währe SVNParentPath vllt angebrachter:

Code: Select all
<Location /svn>
    DAV svn
    SVNListParentPath on
    SVNParentPath "S:\SVN Server\SVNTESTDir\"
</Location>
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: SVN mit Apache

Postby Wiedmann » 03. July 2009 07:25

in deinem Pfad befindet sich ein Leerzeichen, darum musst du den Pfad in Anführungszeichen schreiben:

Und natürlich noch Forward-Slashe benutzen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: SVN mit Apache

Postby skaiser » 03. July 2009 11:41

Ok das leutet ein, den Pfad in "" zu setzten.

Werd es heut abend gleich versuchen, da ich in mom auf Arbeit bin.

Werde dann auch bescheid sagen, ob es so geklappt hat.

Code: Select all
Btw. ist es beabsichtigt das du jetzt jedes Repos einzeln nach /svn/{INSERT-NAME-HERE} verdrahtest?
Ansonsten währe SVNParentPath vllt angebrachter:


Es ist geplant das ganze für mehrere Verzeichnisse/User anzulegen.

Daher auch der Anhang.
skaiser
 
Posts: 9
Joined: 28. April 2009 09:06

Re: SVN mit Apache

Postby skaiser » 03. July 2009 19:15

Habe den Pfad jetzt in Klammern gesetzt und Apache gestartet.

Jetzt funktioniert es wie es sollte.

Vielen dank
skaiser
 
Posts: 9
Joined: 28. April 2009 09:06


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests