Apache2 kann keine Umlaute

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 kann keine Umlaute

Postby ledlenser » 10. December 2003 12:23

Hallo,,
schon wieder ein Problem wo stelle ich beim Apache 2 ein was er mit Umlauten machen soll ? (Ü,Ö,ß)
Er kann auch nichts anfangen mit solchen abfragen (sql und php läuft)
-----------------------------------------------------------------------------
{$query = "select * from buch where Titel like '$anfrage%'";}
----------------------------------------------------------------------------------

Weiß jemand Rat ? :(
ledlenser
 
Posts: 6
Joined: 10. December 2003 08:07

Postby nemesis » 10. December 2003 14:00

hi,

überleg doch mal bitte einmal, schonmal ein müller.de gesehn?
Umlaute gehören nicht in Domainnamen und Dateien/Verzeichnisse.
Grobes bsp. kannst du alle sonderzeichen von französischen oder spanischen Wörtern schreiben? Wäre etwas blöd wenn eine Domain Sonderzeichen drinnen hat.
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby ledlenser » 10. December 2003 14:10

Ich habe mich ein bischen dürftig ausgedrückt, das mit den domänenamen ist mir klar aber aber darum geht es gar nicht

zB diese Abfrage funktioniert super auf öffentliche Webspace (levanzo)
-----------------------------------------------------------------------------
{$query = "select * from buch where Titel like '$anfrage%'";}
----------------------------------------------------------------------------------
Ich habe einen parallelen Webserver bei mir zu Hause (nur um meine Seite zu testen) mit idendischer Struktur (mysql,php)
.Jetzt mußte ich oder wollte ich auf apache2 umbauen ,funktioniert soweit ich habe Datenbankzugriff usw.
Aber obige Abfrage zB.funzt nicht da kommt als Ergebnis die komplette Tabelle
Im IE sehe ich auch keinerlei Umlaute wenn ich im lokalen Netz auf die Seite zugreife
Hat der Apache 2 da ein Problem oder liegt das an der php einstellung
Umlaute irgendwo im text meine ich
Weiß jemand Rat ?
ledlenser
 
Posts: 6
Joined: 10. December 2003 08:07

Postby ledlenser » 10. December 2003 14:52

So das Problem mit den Umlauten habe ich gelöst,
in der htpd.conf den Eintrag "AddDefaultCharset On" gesetzt und alle Umlaute waren wieder da .Aber leider funzt meine kleine php Abfrage immer noch nicht was muß man in der php ini datei oder config.inc.php evtl. noch einstellen ??
ledlenser
 
Posts: 6
Joined: 10. December 2003 08:07

Postby ledlenser » 10. December 2003 16:58

So ich habe noch mal ein bischen getestet (ohne großen Erfolg)
Das obige Script (abfrage) läuft auf einem Öffentlichen( Levanzo) webserver (Apache1.3) Php 4.30. Bei mir zu Hause auf dem Testserver ,Suse 9 apache2,php4.33
geht es nicht.

{$query = "select * from dvd where Titel like '$abfrage%'";}

trage ich aber an statt der variablen "$abfrage%" einen direkten Buchtitel ein wird dieser auch perfekt gefunden

{$query = "select * from dvd where Titel like ' Beispieltitel'";}

Wenn ich also in das Abfrageformular etwas eintrage wird das irgendwie nicht übertragen (die Variable) und die Abfrage wird so durchgeführt als ob ich die Textbox leer gelassen hätte.???
Ich denke mal hier ist irgendwas noch falsch an den globalen Einstellungen von php aber was ..bitte versucht mir mal zu helfen eh ich hier den Herzkasper bekomme:(

So bis dann
ledlenser
 
Posts: 6
Joined: 10. December 2003 08:07

Postby Straffi » 11. December 2003 08:26

Moin ledlenser,

das Problem liegt warscheinlich an der Abfrage. Wenn $abfrage leer ist, sucht SELECT nach '%' - also einem Wortanfang, der in jedem Datensatz != NULL vorhanden ist.
Lass dir doch einfach mal den Inhalt der Variablen $abfrage und $query anzeigen, bevor du die Abfrage ausführst. Irgendwo muss da in deinem PHP-Code ein Fehler sein.



mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests