CGI - Hab schon viel gelesen und auch versucht

Alles, was den Apache betrifft, kann hier besprochen werden.

CGI - Hab schon viel gelesen und auch versucht

Postby Gun-Food » 09. December 2003 12:50

Hi,
binja nicht zum ersten Mal hier: Ich hab ne normale Apache Installation + mod_cgi und so am laufen unter Linux. Alles läuft super außer den CGIs.

Perl gibt folgendes auf der Kommandozeile aus:
perl test.cgi
"
Content-type: text/html

Hallo, Welt.
"
Das funktioniert also. Die erste Zeile ist:
#!/usr/bin/perl;

Der Apache schmeißt beim Aufruf aber nen Fehler 500 und in der Log Datei steht:
Premature end of script headers.

Achja bevor Fragen kommen. In der Config Datei vom Apache ist der SetHandler auf cgi und pl gesetzt. PL Dateien gehen aber auch nicht.
Und das Script Alias läuft auch, weil normale HTML Dateien da drin funktionieren. Die Berechtigungen liegen bei 755 Benutzer root.
Das kann es alos auch nicht sein.

Kann wer weiter helfen??

CU @ ALL
Gun-Food
 
Posts: 8
Joined: 12. July 2003 12:48

Postby Straffi » 09. December 2003 14:41

Moin Gun-Food,

ich machs mal kurz:
http://community.apachefriends.org/f/search.php

Einfach mal Premature eintippen und lesen und probieren und dann wieder melden...


mfg straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48

Schön wärs.

Postby Gun-Food » 09. December 2003 18:23

So hab gesucht und viel probiert. Aber hat alles nichts geholfen.
Habe sogar das normale public_html Verzeichnis für cgis zugänglich gemacht. Hilft aber auch nicht. Jetzt geb ich es erstmal auf. Vielleicht hat ja jemand nochmal ne Idee.

PS: Die Kommandozeile echo 'print "Hallo Welt\n";' | /usr/bin/perl
funzt ohne probleme. Genauso wie die Syntaxüberprüfung mit perl -c test.cgi.
Die sagt auch alles klar.

Bitte um hilfe.


CU @ ALL
Gun-Food
 
Posts: 8
Joined: 12. July 2003 12:48


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests