Frage zu VHosts

Alles, was den Apache betrifft, kann hier besprochen werden.

Frage zu VHosts

Postby steffen » 02. December 2003 08:39

Hallo,

kann mal einer sagen ob das so i.O. ist, oder ob ich da was vergessen hab. Soweit funktioniert das ja, nur hab ich beim Firebird auf einigen Seiten immer so einen Absatz (Leerraum) auf den Seiten. Wenn ich das ganze direkt unter /xampp/htdocs laufen lasse, läuft alles normal (bei allen Browsern) wie es sein sollte.

Code: Select all
NameVirtualHost 192.168.xxx.xxx

<VirtualHost www.xxxxxx.com>
ServerAdmin webmaster@xxxxxx.com
ServerName www.xxxxxx.com
DocumentRoot "d:/is/htdocs/xxxxx/www.xxxxxx.com/"
ScriptAlias /cgi-bin/ /is/htdocs/xxxxx/www.xxxxxx.com/cgi-bin/
ErrorLog "d:/is/htdocs/xxxxx/www.xxxxxx.com/logs/error_log"
<Directory "/is/htdocs/xxxxx/www.xxxxxx.com">
Options Indexes FollowSymLinks MultiViews Includes ExecCGI
</Directory>
</VirtualHost>


Das ganze ist auch in der hosts eingetragen, habe keine Ahnung wieso er da beim Firebird solche Absätze macht. Achso hab das jetzt nochmal getestet, komisch im IE und Opera geht es fehlerfrei und im Firebird nicht.

Gruß Steffen
steffen
 
Posts: 49
Joined: 28. November 2003 08:18
Operating System: Win 7 64bit

VHosts

Postby Gun-Food » 11. December 2003 14:16

Also deine Konfiguration stimmt, wenn man davon ausgehen will, dass du auch CGIs im normalen public_html Verzeichnis ausführen willst.
Sollte dem nicht so sein, musst du unter

<Directory "xxxxxxx/www.xxxxxx.com/public_html"> bei den Options ExecCGI (und nur den!)

wegnehmen und eine extra

<Directory "xxxxxxx/www.xxxxxx.com/cgi-bin">
Options ExecCGI
AllowOverride ALL
Order allow,deny
allow from ALL
</Directory>

hinzufügen.

Sonst sollte alles gehen.

CU @ ALL

-[-Gun-Food-]-
Gun-Food
 
Posts: 8
Joined: 12. July 2003 12:48


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests