index.php file wird nicht geparsed seit XAMPP 1.7.1

Alles, was den Apache betrifft, kann hier besprochen werden.

index.php file wird nicht geparsed seit XAMPP 1.7.1

Postby tapipapst » 15. April 2009 08:48

Folgendes Problem:

Ich habe in meinem Root eine Datei Names index.php liegen.
Aufruf mittels http://localhost/index.php geht gut
Aufruf mittels http://localhost/ bietet mir den Download der php-Datei an.

Konfiguriert sind:
    DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.shtml index.phtml
und
    LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt

Hat da jemand eine Idee, oder bracht ihr noch mehr Daten?
Mit Version 1.7.0 ging das noch.
tapipapst
 
Posts: 2
Joined: 15. April 2009 08:14

Re: index.php file wird nicht geparsed seit XAMPP 1.7.1

Postby tapipapst » 15. April 2009 12:32

OK, OK, selbst ausgetrickst!

Habe das Problem identifiziert und gelöst.
Hatte auch das Problem nach dem Update auf Version 1.7.1, bei dem der Apache erst nicht mehr starten wollte.
siehe auch http://community.apachefriends.org/f/viewtopic.php?f=4&t=34556.
Habe dann die Zeile
    LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"
in httpd-xampp.conf auskommentiert. Somit konnte auch keine PHP-Datei mehr geparst werden.
Später habe ich die Zeile durch
    LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"
ersetzt.
Die nachfolgenden Problem waren nicht durch den Apache bedingt, sondern ganz altbacken durch den cache
des Browsers.

Was man manchmal aus den Augen verliert...
tapipapst
 
Posts: 2
Joined: 15. April 2009 08:14


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests