phpmyadmin - Options FollowSymLinks - AuthUserFile /var/www/

Alles, was den Apache betrifft, kann hier besprochen werden.

phpmyadmin - Options FollowSymLinks - AuthUserFile /var/www/

Postby haarausfall » 14. April 2009 15:30

Hallo zusammen,
ich habe bei mir eine MySQL DB und dafür PHPMYADMIN installiert, welcher sich im Verzeichnis

/usr/share/phpmyadmin befindet. Was mir komisch vorkommt ist, dass PHPMYADMIN nun sowohl über den Port 80
als auch über den Port 443 verfügbar ist, wobei ich nur diesen einen Host in /apache2/sites-available angegeben habe.
Zudem kommt beim PHPMYADMIN auch nicht die Passwortabfrage, die ich gerne hätte.

Wie müsste das aussehen, dass PHPMYADMIN auch nur auf 443 verfügbar wäre und zudem auch die Passwort Abfrage dafür kommen würde?


Code: Select all
<VirtualHost *:443>                                                                                 
        SetEnvIf Request_URI "^/u" dontlog                                                         
        ErrorLog /var/log/apache2/error.log                                                         
        Loglevel warn                                                                               
        SSLEngine On                                                                               
        SSLCertificateFile /etc/apache2/ssl/apache.pem                                             
        ProxyRequests Off                                                                           
                                                                                                                                                 
        DocumentRoot /var/www/out/                                                                 
        <Directory />                                                                               
                Options FollowSymLinks                                                             
                AllowOverride None                                                                 
        </Directory>                                                                               
                                                                                                   
        <Proxy *>                                                                                   
                AuthUserFile /var/www/ssl/.htpasswd                                                 
                AuthName EnterPassword                                                             
                AuthType Basic                                                                     
                require valid-user                                                                 
                                                                                                   
                Order deny,allow                                                                   
                Allow from all                                                                     
        </Proxy>                                                                                   
        ProxyPass /ssh/ http://localhost:8022/                                                     
        ProxyPassReverse /ssh/ http://localhost:8022/                                               
                                                                                                   
    Alias /doc/ "/usr/share/doc/"                                                                   
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks                                                   
        AllowOverride None                                                                         
        Order deny,allow                                                                           
        Allow from all                                                                             
        Allow from 127.0.0.0/255.0.0.0 ::1/128                                                     
               AuthUserFile /var/www/ssl/.htpasswd                                                 
                AuthName EnterPassword                                                             
                AuthType Basic                                                                     
                require valid-user                                                                 
                                                                                                   
   </Directory>                                                                                     
                                                                                                   
</VirtualHost>     


Viele Grüsse & schon mal vielen Dank,
Markus

P.S. Das ganze läuft auf einem Ubuntu Server.
haarausfall
 
Posts: 14
Joined: 09. March 2007 14:07

Re: phpmyadmin - Options FollowSymLinks - AuthUserFile /var/www/

Postby Wiedmann » 14. April 2009 15:37

Zudem kommt beim PHPMYADMIN auch nicht die Passwortabfrage, die ich gerne hätte.

Wird im phpMyAdmin manual genau beschrieben.


/usr/share/phpmyadmin befindet. Was mir komisch vorkommt ist, dass PHPMYADMIN nun sowohl über den Port 80
als auch über den Port 443 verfügbar ist, wobei ich nur diesen einen Host in /apache2/sites-available angegeben habe.

Hast du irgendwo einen Alias für "/usr/share/phpmyadmin" eingerichtet, oder ist "/usr/share" dein DocumentRoot für den Default Host (auf Port 80)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: phpmyadmin - Options FollowSymLinks - AuthUserFile /var/www/

Postby haarausfall » 14. April 2009 16:08

Wiedmann wrote:
Zudem kommt beim PHPMYADMIN auch nicht die Passwortabfrage, die ich gerne hätte.

Wird im phpMyAdmin manual genau beschrieben.

Von der PHPMYADMIN Seite aus habe ich schon einen ganz normalen sessionbasierten Loginmechanismus. Nur hättte ich da gerne oben drauf noch ein:

Code: Select all
       
AuthUserFile /var/www/ssl/.htpasswd                                                 
AuthName EnterPassword                                                             
AuthType Basic                                                                     


/usr/share/phpmyadmin befindet. Was mir komisch vorkommt ist, dass PHPMYADMIN nun sowohl über den Port 80
als auch über den Port 443 verfügbar ist, wobei ich nur diesen einen Host in /apache2/sites-available angegeben habe.

Hast du irgendwo einen Alias für "/usr/share/phpmyadmin" eingerichtet, oder ist "/usr/share" dein DocumentRoot für den Default Host (auf Port 80)?


Nein. Hab mal eben danach gesucht und kann dazu auch keinen Symlink finden. Jetzt habe ich mal noch die default site auf folgendes reduziert:

Code: Select all
<VirtualHost *:443>                                                                                 
        SetEnvIf Request_URI "^/u" dontlog                                                         
        ErrorLog /var/log/apache2/error.log                                                         
        Loglevel warn                                                                               
        SSLEngine On                                                                               
        SSLCertificateFile /etc/apache2/ssl/apache.pem                                             
        ProxyRequests Off                                                                           
                                                                                                                                               
        DocumentRoot /var/www/out/                                                                 
        <Directory />                                                                               
                Options FollowSymLinks                                                             
                AllowOverride None                                                                 
        </Directory>                                                                               
                                                                                                   
        <Proxy *>                                                                                   
                AuthUserFile /var/www/ssl/.htpasswd                                                 
                AuthName EnterPassword                                                             
                AuthType Basic                                                                     
                require valid-user                                                                 
                Order deny,allow                                                                   
                Allow from all                                                                     
        </Proxy>                                                                                   
        ProxyPass /ssh/ http://localhost:8022/                                                     
        ProxyPassReverse /ssh/ http://localhost:8022/                                               
                                                                                                   
                                                                                                   
</VirtualHost> 



Ergebnis ist nach wie vor das gleiche. phpmyadmin lauscht noch auf Port 80, obwohl ich Port 80 nirgendwo eingetragen habe :?

Mein Ziel ist es, dass auf Port 80 gar nichts mehr kommt. Nur noch auf Port 443.

Viele Grüsse,
Markus
haarausfall
 
Posts: 14
Joined: 09. March 2007 14:07

Re: phpmyadmin - Options FollowSymLinks - AuthUserFile /var/www/

Postby Wiedmann » 14. April 2009 16:40

Hast du irgendwo einen Alias für "/usr/share/phpmyadmin" eingerichtet, oder ist "/usr/share" dein DocumentRoot für den Default Host (auf Port 80)?

Nein

Dann könnte man phpMyAdmin überhaupt nicht aufrufen.
--> Woher sollte der Apache sonst wissen, dass in "/usr/share/phpmyadmin" der phpMyAdmin über z.B. "http://loclahost/phpmyadmin/" zu erreichen ist?

und kann dazu auch keinen Symlink finden.

Kann natürlich auch ein Symlink im DocumentRoot deines Port 80 Default Hosts sein. (Und ich mein hier nicht den DocumentRoot von deinem Port 443 Default Host)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests