Zugriffsverweigerung unberechtigt !?

Alles, was den Apache betrifft, kann hier besprochen werden.

Zugriffsverweigerung unberechtigt !?

Postby cMasterXC » 14. April 2009 11:38

Hallo Zusammen!

Also, zu aller erst die Gegebenheiten, ich nutze XAMPP unter Win Home Server. Weil WHS den IIS mitbringt und somit Port 80 belegt, habe ich Apache für das HTTP- sowie HTTPS-Protokoll einen anderen Port zugewiesen. Soweit funktioniert das einwandfrei.

Allerdings habe ich folgendes Problem: Auf "http://localhost/security/" wird nur vom localhost Zugriff gewährt, was ich beim Verzeichnis "/xampp/" auch so einstellen möchte. Folgedessen habe ich folgenden Code auch beim xampp-Verzeichnis in der Datei "httpd-xampp.conf" reinkopiert:
Code: Select all
Order deny,allow
Deny from all
Allow from localhost

Soweit sogut.
Wenn ich diesen Code nicht drin habe, dann auf "http://localhost/xampp/" zugreife, und anschließend die access.log anschaue, hat er bei Quell-IP localhost drinstehen. Wenn ich diesen Code dann allerdings reinschreibe, die "http://localhost/xampp/"-Seite aktualisiere, und die access.log anschaue, hat er bei Quelle nicht mehr localhost drinstehen, sondern "HS" (der Name des Home-Servers auf dem dieser Apache läuft), weshalb er mir dann auch den Zugriff auf das Verzeichnis "xampp" verweigert. Genau der selbe Effekt ist auch beim Alias "/security".

Woran liegt das und wie kann ich das Problem beheben?

Schon im Vorraus, Vielen Dank für Eure Hilfe!

Gruß Stefan
cMasterXC
 
Posts: 2
Joined: 26. March 2009 16:56
Location: Deutschland

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests