Rewrite not working with ssl (Urgent)

Alles, was den Apache betrifft, kann hier besprochen werden.

Rewrite not working with ssl (Urgent)

Postby Bojan.Hrnkas » 31. March 2009 10:45

Hello!

I have a website where all requests for non-existing files or folders are being sent to index.php. It works great with standard http on port 80. When I try to access such "non-existing" file over https, I get 404 error. SSL itself is working fine, since I can get existing files over https.

My rewrite rule in .htaccess is:
Code: Select all
<IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on

# Note! I tried it with and without RewriteBase, but the problem remains
#  RewriteBase /

    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule .* index.php [L]

</IfModule>

RewriteLog is on level 3 and there are no reports if I access the site over https.

Any idea what might be wrong?
Bojan.Hrnkas
 
Posts: 2
Joined: 31. March 2009 10:35

Re: Rewrite not working with ssl (Urgent)

Postby Bojan.Hrnkas » 31. March 2009 10:51

Forget it!
In my virtualhost for port 443 I had AllowOverride none for this folder. But it is just tipicall. After fighting with the problem for days, I write a question in a forum, and a few seconds later I find the solution myself.

Greets! :)
Bojan.Hrnkas
 
Posts: 2
Joined: 31. March 2009 10:35


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests