Nur https und kein http mehr !

Alles, was den Apache betrifft, kann hier besprochen werden.

Nur https und kein http mehr !

Postby timee » 20. March 2009 23:42

Hallo,

ich habe LAMPP mit SSL installiert und gestartet!
Der Webserver läuft und ich kann mich sowohl über http, als auch über https einloggen.

Jedoch möchte ich nur https erlauben, jeglicher Zugang über http soll nicht mehr funktionieren, ist das möglich?


THX
timee
timee
 
Posts: 16
Joined: 20. March 2009 23:35

Re: Nur https und kein http mehr !

Postby Nobbie » 21. March 2009 10:37

Einfach nicht mehr auf Port 80 "Listen". Nur noch Port 443.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: Nur https und kein http mehr !

Postby timee » 22. March 2009 15:02

wenn ich unter /opt/lampp/etc/httpd.conf den Eintrag Listen 80 auf Listen 443 ändere und dann neu starte, kommt folgende Fehlermeldung:

Starting XAMPP for Linux 1.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP for Linux started.
timee
 
Posts: 16
Joined: 20. March 2009 23:35

Re: Nur https und kein http mehr !

Postby Wiedmann » 22. March 2009 15:04

wenn ich unter /opt/lampp/etc/httpd.conf den Eintrag Listen 80 auf Listen 443 ändere

Du solltst den Eintrag nicht ändern sondern entfernen:
--> Einen Eintrag für 443 gibts es ja logischerweise bereits, sonst könntest du bisher ja kein HTTPS benutzen. Und da du kein HTTP haben willst, musst du dafür eben den Eintrag für den HTTP Port entfernen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Nur https und kein http mehr !

Postby timee » 22. March 2009 17:10

Ok, danke für die Hilfe!
timee
 
Posts: 16
Joined: 20. March 2009 23:35


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests