FancyIndexing: Symbole werden nicht angezeigt

Alles, was den Apache betrifft, kann hier besprochen werden.

FancyIndexing: Symbole werden nicht angezeigt

Postby Jimini » 19. March 2009 00:43

Hallo,
nachdem ich heute den ganzen Tag nach der Ursache gesucht und gegoogelt habe, habe ich mich jetzt hier registriert, weil ich absolut nicht weiterkomme.

Ich habe hier einen Rechner mit folgender Konfiguration:
Apache/2.2.10 (Gentoo) mod_ssl/2.2.10 OpenSSL/0.9.8j PHP/5.2.8-pl2-gentoo Server at ***.***.*** Port 80

Auf diesem habe ich das FancyIndexing aktiviert, allerdings werden in Directories, in denen sich keine index-Datei befindet, die Symbole der Dateitypen nicht angezeigt, sie fehlen völlig. Natürlich liegen sie im richtigen Verzeichnis /var/www/localhost/icons.

httpd.conf:
Code: Select all
ServerRoot "/usr/lib/apache2"

LoadModule authz_host_module modules/mod_authz_host.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dir_module modules/mod_dir.so
LoadModule mime_module modules/mod_mime.so
<IfDefine PROXY>
LoadModule proxy_module modules/mod_proxy.so
</IfDefine>
<IfDefine PROXY>
LoadModule proxy_connect_module modules/mod_proxy_connect.so
</IfDefine>
<IfDefine PROXY>
LoadModule proxy_http_module modules/mod_proxy_http.so
</IfDefine>
<IfDefine SSL>
LoadModule ssl_module modules/mod_ssl.so
</IfDefine>

User apache
Group apache

Include /etc/apache2/modules.d/*.conf

Include /etc/apache2/vhosts.d/*.conf


00_mod_autoindex.conf:
Code: Select all
<IfModule autoindex_module>
<IfModule alias_module>

Alias /icons/ "/var/www/localhost/icons/"

<Directory "/var/www/localhost/icons">
        Options Indexes MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
</Directory>
</IfModule>

IndexOptions FancyIndexing FoldersFirst

AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*

AddIcon /icons/binary.gif .bin .exe
AddIcon /icons/binhex.gif .hqx
AddIcon /icons/tar.gif .tar
AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
AddIcon /icons/a.gif .ps .ai .eps
AddIcon /icons/layout.gif .html .shtml .htm .pdf
AddIcon /icons/text.gif .txt
AddIcon /icons/c.gif .c
AddIcon /icons/p.gif .pl .py
AddIcon /icons/f.gif .for
AddIcon /icons/dvi.gif .dvi
AddIcon /icons/uuencoded.gif .uu
AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
AddIcon /icons/tex.gif .tex
AddIcon /icons/bomb.gif core

AddIcon /icons/back.gif ..
AddIcon /icons/hand.right.gif README
AddIcon /icons/folder.gif ^^DIRECTORY^^
AddIcon /var/www/localhost/icons/blank.gif ^^BLANKICON^^

DefaultIcon /icons/unknown.gif

IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
</IfModule>


Hat jemand eine Idee, woran es liegen könnte? Sollte ich etwas vergessen haben zu erwähnen, bitte Bescheid sagen - ich reiche es dann nach.

MfG Jimini
Jimini
 
Posts: 9
Joined: 19. March 2009 00:13

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests