.htaccess nach distupgrade

Alles, was den Apache betrifft, kann hier besprochen werden.

.htaccess nach distupgrade

Postby the thing » 14. March 2009 22:58

*edit

hab den Fehler gefunden
ein direktiv in sites-enabled hat das 80er direktiv das ich alt hergebracht in der httpd.conf habe
immer wieder überschrieben und allowoverride auf none gestellt. hab das neue direktiv einfach rausgenommen,
jetzt liest er .htaccess wieder


______________________________________________________________________________________________________

Hallo!
Ich habe mir vor geraumer Zeit selbst ein CMS geschrieben, klein, für meine Verhältnisse allerdings vollkommen
ausreichend. Entsprechend hatte mein CMS ein kleines backend - ein interface.
Ich hatte dieses Backend einfach in einem Ordner namens "admin" und davor eine .htaccess
Das ganze lief biesher immer wunderbar, bis offenbar vor knapp einer woche, als ich auf meinem
Linux system ein dist upgrade gemacht habe.
Ich benutzt ubuntu als server version und habe jetzt v8.10 drauf. Ich habe von feisty fawn geupgradet,
da liegen schon einige monate zwischen, daher sind da auch ein paar neue pakete, unter anderem auch der
apache in einer neuen version gekommen.

Jetzt zu meinem Problem: Offenbar ignoriert der Apache atm die htaccess völlig. Allerdings nur auf meinem
primören host! Ich habe noch einen weiteren virtuellen server laufen der auf einen anderen port lauscht
und dieser ist --komplett-- durch eine htaccess geschützt. Hier funktioniert es, hier fragt er benutzernamen
und passwort ab. Aber im admin ordner meiner webseite nicht. Das ist mir jetzt schätzungweise eine woche
süäter aufgefallen und entweder ein bot oder in besucher hat mir die komplette datenbank über das ungeschützte
backend leer geräumt.

Meine frage jetzt ist, wie kann das sein?!
Sowas darf doch nicht passieren. Der apache rückt doch eine keine inc.php dateien raus wenn das PHP modul down
ist, wieso sagt er nicht das die htaccess bitte zu modifizieren ist, wenn er sie nicht mehr lesen oder benutzen kann
statt einfach ohne rücksicht auf verluste den inhalt auszuspucken?!

Kann das was mit den overrid einstellungen zu tun haben ?

hat sich da in den letzen versionen was geändert?

danke im voraus LG

*edit

NameVirtualHost *:80
#
<VirtualHost *:80>
<Directory /var/www>
Options +ExecCGI +Indexes +FollowSymLinks
AllowOverride All
</Directory>
<Directory /usr/share/phpmyadmin>
Options ExecCGI Indexes
AllowOverride All
</Directory>

DocumentRoot /var/www
CustomLog /var/log/apache2/port80access.log combined
</VirtualHost>


Listen 90
NameVirtualHost *:90
#
<VirtualHost *:90>
<Directory /var/swww>
AllowOverride All
</Directory>

DocumentRoot /var/swww
CustomLog /var/log/apache2/port90access.log combined
</VirtualHost>

Listen 100
NameVirtualHost *:100
#
<VirtualHost *:100>
<Directory /var/www2>
AllowOverride All
</Directory>

DocumentRoot /var/www2
CustomLog /var/log/apache2/port100access.log combined
</VirtualHost>



*edit

niemand eine Ahnung wieso mein apache htaccess ignoriert ?!


*edit

beim starten des webservers meldet er

[warn] NameVirtualHost *:80 has no VirtualHosts
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests