Immernoch ein Problem mit VirtualDocumentRoot

Alles, was den Apache betrifft, kann hier besprochen werden.

Immernoch ein Problem mit VirtualDocumentRoot

Postby heinetz » 09. March 2009 20:21

Hallo Forum,

ich habe nach wie vor ein Problem mit der Kombination von 2 vhosts.
Einem mit VirtualDocumentRoot ohne Servernamen und einem mit
normalem DocumentRoot mit ServerName.

Meine vhosts.conf sieht zur Zeit so aus:

Code: Select all
NameVirtualHost *:80
NameVirtualHost *:443

<Directory "/Users/martinhein/Sites">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    VirtualDocumentRoot /Users/martinhein/Sites/%1
</VirtualHost>

<VirtualHost *:80>
    ServerName localhost
    ServerAlias leopold   
    ServerAlias 127.0.0.1   
    DocumentRoot "/Applications/xampp/xamppfiles/htdocs"
</VirtualHost>


Alle Anfragen an '*.leopold.net' werden von meinem lokalen Nameserver
nach 127.0.0.1 geschickt. So wird z.B. das Verzeichnis:

/Users/martinhein/Sites/test

... per Browser über:

http://test.leopold.net

... erreichbar.

Jetzt hätte ich gerne erreicht, dass der Aufruf von z.B:

http://test_b.leopold.net

... den Inhalt von 'localhost' zeigt, wenn es kein Verzeichnis:

/Users/martinhein/Sites/test_b gibt

Statt dessen gibt es zur Zeit ein '404 The URL / not found'

Kann mir jemand einen Tipp geben, wie ich das hinbekomme ?


tausend Dank und

beste gruesse,
heinetz
heinetz
 
Posts: 88
Joined: 02. January 2004 12:37

Re: Immernoch ein Problem mit VirtualDocumentRoot

Postby Nobbie » 10. March 2009 23:55

>Alle Anfragen an '*.leopold.net' werden von meinem lokalen Nameserver

Sorry, aber dieses Statement ist total sinnfrei. Ein Nameserver schickt keine Anfragen an Webserver. Das ist Quatsch hoch zehn.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests