merkwürdiges Verhalten

Alles, was den Apache betrifft, kann hier besprochen werden.

merkwürdiges Verhalten

Postby heinetz » 28. February 2009 20:38

Hallo Forum,

meine /etc/hosts sieht wie folgt aus:

Code: Select all
127.0.0.1   root.home.net
127.0.0.1   localhost
127.0.0.1   leopold
127.0.0.1 test.leopold.net
127.0.0.1 testzwei.leopold.net
127.0.0.1 testdrei.leopold.net
127.0.0.1 testvier.leopold.net


diese verzeichnisse gibt es unter /Users/martinhein/Sites/:

test
testzwei
testvier

und meine vhosts habe ich wie folgt defniert:

Code: Select all
NameVirtualHost *:80
NameVirtualHost *:443

<Directory "/Users/martinhein/Sites">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    ServerName localhost
    ServerAlias leopold     
    ServerAlias 127.0.0.1   
    DocumentRoot "/Applications/xampp/xamppfiles/htdocs"
</VirtualHost>

<VirtualHost *:80>
    VirtualDocumentRoot /Users/martinhein/Sites/%1
</VirtualHost>


Erreichen möchte ich damit, dass alle http-Requests, die auf 127.0.0.1 zeigen,
den Inhalt von DocumentRoot "/Applications/xampp/xamppfiles/htdocs"
anzeigen, wenn unter /Users/martinhein/Sites/ kein Verzeichnis nach dem Muster
<verzeichnisname>.leopold.net vorhanden ist. Das Ergebnis ist allerdings
eigenartig:

Nur http://testzwei.leopold.net/ zeigt den Inhalt des Verzeichnisses 'testzei'
an. Z.B. http://test.leopold.net/ wird nicht gefunden und statt dessen wird
der Inhalt von /Applications/xampp/xamppfiles/htdocs angezeigt.

Ich habe keine Idee, was dazu führen könnte.

Hat jemd einen Tipp für mich ?

danke und
beste gruesse,
heinetz
heinetz
 
Posts: 88
Joined: 02. January 2004 12:37

Nachtrag

Postby heinetz » 28. February 2009 20:55

Wenn ich die Reihenfolge der vhosts wie folgt ändere:

Code: Select all
NameVirtualHost *:80
NameVirtualHost *:443

<Directory "/Users/martinhein/Sites">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    VirtualDocumentRoot /Users/martinhein/Sites/%1
</VirtualHost>

<VirtualHost *:80>
    ServerName localhost
    ServerAlias leopold     
    ServerAlias 127.0.0.1   
    DocumentRoot "/Applications/xampp/xamppfiles/htdocs"
</VirtualHost>


... wird der Inhalt der vorhanden Verzeichnisse beim jeweiligen
entsprechenden Aufruf korrekt angezeigt. Wenn allerdings auf
ein nicht vorhandenes Verzeichnis (z.B. mit http://testdrei.leopold.net/)
verwiesen wird, ist die Ausgabe des Browsers:

Not Found

The requested URL / was not found on this server.

... was auch wohl korrekt ist. Allerdings möchte ich
ja erwirken, dass dann der Inhalt von http://localhost
angezeigt wird. Nur habe ich keine Ahnung wie ich das
machen soll.

Hat jemand einen Tipp ?

danke und

beste gruesse,
heinetz
heinetz
 
Posts: 88
Joined: 02. January 2004 12:37


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests