apache will einfach nicht starten (Portsache?)

Alles, was den Apache betrifft, kann hier besprochen werden.

apache will einfach nicht starten (Portsache?)

Postby keule84 » 15. February 2009 16:18

Also ich hab jetzt wahrscheinlich nicht soviel ahnung wie ihr daher frag ich einfach mal. Ich habe mir mit einem kumpel einen root gemietet vor standard plesk drauf ist. Nun möchten wir aber datenbanken mit xampp verwalten/anlegen. Nur das es einfach nicht geht. (davor auf unseren rechnern gings ohne probleme) Wir haben xampp standart installiert und es geht schon los das er apache nichtmal startet:

Image

hierzu die portbelegung:

Image

wie man sehen kann ist port 80 vom system belegt und 443 soll frei sein.

Nun zu den fragen: wie krieg ich raus was genau port 80 belegt und wie kann ich den dann für xammp nutzbar machen, und warum steht bei port 443 free, aber xampp nimmt in sich nicht? wie gesagt das ist alles noch gutes neuland für uns und ohne hilfe kommen wir jetzzt echt nichtmehr weiter. ich vermute das das alles mit dem Plesk zu tun hat. da es auch apache dienste anbietet...

danke
keule84
 
Posts: 5
Joined: 15. February 2009 16:00

Re: apache will einfach nicht starten (Portsache?)

Postby Wiedmann » 15. February 2009 16:27

Nun zu den fragen: wie krieg ich raus was genau port 80 belegt

z.B. netstat oder tcpview.

und wie kann ich den dann für xammp nutzbar machen,

Indem du den Server der da schon läuft stoppst (bzw. am Starten hinderst).

und warum steht bei port 443 free, aber xampp nimmt in sich nicht?

Weil:
a) der "XAMPP" sich gar keine Ports nimmt ;-)
b) sich wenn, der Apache den Port nehmen würde. Aber da dieser nicht startet weil schon der Port 80 belegt ist, er also gar nicht läuft, kann er auch keinen Port belegen.

wie gesagt das ist alles noch gutes neuland für uns ... Ich habe mir mit einem kumpel einen root gemietet

Neuland und Rootserver ist wirklich eine ungesunde Mischung... Aber warum benutzt ihr nicht einfach den Webserver der schon bei dem Rootserver dabei ist?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache will einfach nicht starten (Portsache?)

Postby keule84 » 15. February 2009 16:34

Aber warum benutzt ihr nicht einfach den Webserver der schon bei dem Rootserver dabei ist?


weil wir uns mit der datenbankverwaltung/anlegung/problembehebung bei xampp gut auskennen. Nur das bis dato, immer die installation von xampp gereicht hatte. Und wir direkt in phpmyadmin reinkamen, was diesmal net der fall ist x_X

also wenn ich das richtig verstanden habe: muss ich erstmal analysieren wer den port 80 belegt und dann sollte es gehen? ich schau mal ob ich mit deinen tips weiterkomme, auf jeden fall haben sie mitr schonmal en wenig mehr licht ins dunkle gebracht. danke
keule84
 
Posts: 5
Joined: 15. February 2009 16:00

Re: apache will einfach nicht starten (Portsache?)

Postby Xardas der Dunkle » 15. February 2009 16:45

weil wir uns mit der datenbankverwaltung/anlegung/problembehebung bei xampp gut auskennen. Nur das bis dato, immer die installation von xampp gereicht hatte. Und wir direkt in phpmyadmin reinkamen, was diesmal net der fall ist x_X

Schwachsinn. Um ans phpmyadmin ran zukommen muss man eben nur den Umweg übers Plesk machen, aber ansonsten ist alles gleich.
Das einzige könnte sein, das auf dem root eben kein Apache sondern standardmäßig der IIS läuft (kann man, aber glaube ich im Plesk umstellen!?).
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: apache will einfach nicht starten (Portsache?)

Postby keule84 » 15. February 2009 22:52

die sache ist wir haben absolut 0 plan von plesk, daher wollten wir es alles über xampp machen, nur leider startet der apache dienst von xampp auf teufel komm raus nicht. Port 80 ist vom system belegt, wir haben jetz versucht genauer rauszukriegen welcher. was aber noch nicht wirklich zum erfolg geführt hat. ein programm gibt auch nicht wirklich aufschluss darauf:

Image

viell einer so nett sich mit mir mal im TS oder per fernwartung zu beschäftigen? ich glaube das führt so zu keinem erfolg. Seid tagen lesen wir hier 100e von foren aber kommen einfach nciht weiter. das ziel ist ganz einfach: wir wollen in die datenbankverwaltung von xampp (bzw ins phpmyadmin) wozu der port 80 ja belegt sein muss. sofern ich da jetz nicht völlig falsch liege.

Mal ganz primitiv ausgedrückt:

hier will ich hin:
Image

hier komm ich hin:

Image
keule84
 
Posts: 5
Joined: 15. February 2009 16:00

Re: apache will einfach nicht starten (Portsache?)

Postby Xardas der Dunkle » 16. February 2009 00:32

die sache ist wir haben absolut 0 plan von plesk

Einarbeiten? Plesk ist, um es hart auszudrücken, für Leute gemacht die eben nicht so viel Ahnung von Serverkonfiguration haben und daher eigentlich relativ simpel.

Wenn du da zu keine Lust hast, dann darfst du dir auch keinen root zulegen. Tut mir leid, aber so ist es.

Und wie es aussieht läuft bereits der IIS/Apache vom Plesk auf dem Port 80. Beende ihn einfach und dein Problem ist gelöst ;).

Und ins Plesk zukommen, versuch mal anstatt die loopback-Adresse die IP deines Servers in die Adresszeile einzugeben.
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: apache will einfach nicht starten (Portsache?)

Postby keule84 » 16. February 2009 06:02

einarbeiten? was denkst du waws wir seid tagen machen. nur ist die materie für neulinge nicht gerade leicht, sry.

so jetz sind wir weiter. kommen in xampp rein (127.0.0.1/xampp), xampp belegt auch alle ports wie es sein soll. nur jetzt kommen wir nicht in phpmyadmin x_X (apache und mysql laufen ordungsgemäss) wieso? woran kanns liegen? (auf mein andern rechner geht alles ohne probleme warum nur auf diesen **** root nicht)
keule84
 
Posts: 5
Joined: 15. February 2009 16:00


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests