Fehler: user_agent aussperrung geht nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Fehler: user_agent aussperrung geht nicht

Postby ZodiacXP » 09. February 2009 20:22

So sieht 's aus:
Code: Select all
RewriteCond %{HTTP_USER_AGENT} ^Chrome.* [NC]
RewriteRule ^/.*$ - [L,F]


Und ich gehe mit dem Chrome Browser rein und statt 403 Forbidden wird die Seite angezeit.

Wo ist mein Denkfehler?
ZodiacXP
 
Posts: 21
Joined: 01. August 2005 07:01
Location: In einem Haus

Re: Fehler: user_agent aussperrung geht nicht

Postby Wiedmann » 09. February 2009 20:28

Wo ist mein Denkfehler?

Indem du dir anschaust, ob der UserAgent von deinem Brower überhaupt mit dem Wort "Chrome" anfängt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Fehler: user_agent aussperrung geht nicht

Postby ZodiacXP » 09. February 2009 20:30

Stimmt ja das Pattern ist falsch. Habe es geändert:

Code: Select all
RewriteCond %{HTTP_USER_AGENT} ^.*Chrome.* [NC]
RewriteRule ^/.* - [L,F]


Ging nicht. Und dann ganz allgemein alles ausgesperrt:

Code: Select all
RewriteCond %{HTTP_USER_AGENT} ^.* [NC]
RewriteRule ^/.* - [L,F]


Wurd auch nichts. Natürlich steht RewriteEngine On davor.
Werde daraus nicht schlau. Am Ende genau so wie es bei apache.org empfohlen wird.
http://httpd.apache.org/docs/1.3/mod/mo ... ewriteCond
ZodiacXP
 
Posts: 21
Joined: 01. August 2005 07:01
Location: In einem Haus

Re: Fehler: user_agent aussperrung geht nicht

Postby Wiedmann » 10. February 2009 07:35

Hast du das in einer ".htaccess", oder in einem Directory-/Location-Block drin? Dann müsstest du den Slash bei der Rule weglassen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests