Cannot load ***/mod_alias.so (ist aber vorhanden)

Alles, was den Apache betrifft, kann hier besprochen werden.

Cannot load ***/mod_alias.so (ist aber vorhanden)

Postby Martze » 08. February 2009 12:22

Hi

ich habe folgendes Problem

starte ich den Server erscheint bei mir folgende Meldung:

Code: Select all
root@v30930:/usr/local/apache2# apache2ctl -k start
[Sun Feb 08 12:08:00 2009] [warn] module cgi_module is already loaded, skipping
Syntax error on line 72 of /etc/apache2/httpd.conf:
Cannot load /usr/lib/apache2/modules/mod_alias.so into server: /usr/lib/apache2/modules/mod_alias.so: cannot open shared object file: No such file or directory


Ich kann mir die nicht erklären, da:
1. in Zeile 72 nichts steht

Code: Select all
69  # User/Group: The name (or #number) of the user/group to run httpd as.
70  # It is usually good practice to create a dedicated user and group for
71  # running httpd, as with most system services.
72
73  User nodody
74  Group nobody



2. mod_alias statisch einkompiliert ist

Code: Select all
root@v30930:/usr/local/apache2# apache2ctl -l
Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_log_config.c
  mod_logio.c
  mod_env.c
  mod_setenvif.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_negotiation.c
  mod_dir.c
  mod_alias.c
  mod_so.c


3. nirgends in irgendeiner *.conf-datei sowas wie include mod_alias.so steht

Als Symptombekämpfung hab ich dann mal nachträglich mod_alias.so als shared object eingefügt, der Fehler bleibt aber.

habe bereits gegoogelt, und auch die Forensuche genutzt, aber nichts gefunden.

Versionen:
Ubuntu 6.06.1 LTS
Linux 2.6.9-023stab043.1-smp
apache2.2.11

Wäre nett, wenn mir da jemand helfen könnte

Gruß Martze
Martze
 
Posts: 1
Joined: 08. February 2009 12:08

Re: Cannot load ***/mod_alias.so (ist aber vorhanden)

Postby Wiedmann » 09. February 2009 00:50

3. nirgends in irgendeiner *.conf-datei sowas wie include mod_alias.so steht

Nach der Fehlermeldung wird das aber definitiv wo stehen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cannot load ***/mod_alias.so (ist aber vorhanden)

Postby Nobbie » 09. February 2009 09:41

Ich vermute mal, dass Du in der falschen httpd.conf schaust, oder im falschen error.log, oder oder oder - irgendetwas ist da "schräg".
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests