New install!! new to xampp help!!

Alles, was den Apache betrifft, kann hier besprochen werden.

New install!! new to xampp help!!

Postby gpittingale » 03. February 2009 21:56

Hi everyone, I have sucessfully installed xampp on my pc then I set dreamweaver to test the files directly on the server (I put the files in xampp/php/www/my_folder_name) however.....when i used dreamweaver to test the files all the php code is displayed in the browers as if it is html and it irratating me now!!!! does anybody know where i have gone wrong?

Thanks in advance.
gavin
gpittingale
 
Posts: 2
Joined: 03. February 2009 21:24

Re: New install!! new to xampp help!!

Postby Izzy » 03. February 2009 22:31

Try putting your folder in xampp\htdocs folder then change that location in DW and make sure Apache is running so that php files can be parsed.

Any error messages in the xampp\apache\logs\error.log file, that is if you had Apache started before running the php files in DW?

php files have to go through the server so what address in the browser did you see?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New install!! new to xampp help!!

Postby gpittingale » 03. February 2009 22:47

[Tue Feb 03 16:30:48 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 03 16:30:48 2009] [notice] Digest: done
[Tue Feb 03 16:30:49 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Feb 03 16:30:49 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Feb 03 16:30:49 2009] [notice] Parent: Created child process 6432
[Tue Feb 03 16:30:50 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 03 16:30:50 2009] [notice] Digest: done
[Tue Feb 03 16:30:51 2009] [notice] Child 6432: Child process is running
[Tue Feb 03 16:30:51 2009] [notice] Child 6432: Acquired the start mutex.
[Tue Feb 03 16:30:51 2009] [notice] Child 6432: Starting 250 worker threads.
[Tue Feb 03 16:30:51 2009] [notice] Child 6432: Starting thread to listen on port 443.
[Tue Feb 03 16:30:51 2009] [notice] Child 6432: Starting thread to listen on port 80.
[Tue Feb 03 16:37:33 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Feb 03 16:54:03 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/CFIDE
[Tue Feb 03 16:54:13 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/CFIDE
[Tue Feb 03 16:55:17 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/scdc_files
[Tue Feb 03 16:57:31 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/CFIDE
[Tue Feb 03 16:59:09 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/CFIDE
[Tue Feb 03 16:59:26 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/CFIDE

ok heres the error log, Itried what you said int he last comment and it was A NO GO!!

i orignally used fro a web address http://localhost/brucesenvironment.co.uk/index.php

i just used file:///C:/xampp/htdocs/brucesenvironment.co.uk/index.php

getting a bit stumped now but just for your info i did earlier on have three attemps at installing this so i didnt know wheather or not th error log would have reme,bered anything from those installs.(I only have one install now though(1 set of files))
gpittingale
 
Posts: 2
Joined: 03. February 2009 21:24

Re: New install!! new to xampp help!!

Postby Izzy » 03. February 2009 23:31

i orignally used fro a web address http://localhost/brucesenvironment.co.uk/index.php

i just used file:///C:/xampp/htdocs/brucesenvironment.co.uk/index.php


First one - is the folder brucesenvironment.co.uk in the htdocs folder and is the server running?
Check in the XAMPP Control Panel (XCP) xampp\xampp-control.exe for a green running next to Apache and MySQL

Second one - this will never work, as I said the php code has to be parsed by a web server using an http://address

Make sure your DW configuration is correct for the Apache server - Server model: PHP MySQL

The CFIDE error is related to a ColdFusion setting.
DW looks for CFIDE if the Testing Server Server model is set to the default of None or ColdFusion and because you may not have configured the Testing Server correctly, it is looking for CFIDE in the xampp htdocs localhost folder - see above re Server model.

I can check your DW conf for the local site as follows (this from MX4 so yours maybe slighly different but the equivalents will be fine:

In the Site Manager in DW what do the following entries have?

Tab - Advanced/Local Info:-
Site Name:
Local Root Folder:
Default Image Folder:
HTTP address:

Tab - Advanced/Testing Server:-
Server Model:
Access:
Testing Server Folder:
Url Prefix:

You may also want to do a forum search in XAMPP for Windows for virtualhost or vhosts as using a virtual host may be an advantage.

I have MX4 installed (old) and still working fine using XAMPP and a vhost for mysite, if it helps - mysite can be your choice, for example ServerName brucesenvironment then when you type in your browser http://brucesenvironment you will go to where ever your site is located anywhere on your PC.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests