Probleme mit der .htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 17:58

Hallo Leute ,

Ich habe Folgendes Problem mit meinen VServer.
Sobald ich eine .htaccess schreibe zeigt der server direckt Zugriff verweigert .

Ich benötige diese infos damit ich bei meinem CMS Ilch 1.1 ein user banner benutzen kann.
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby Wiedmann » 21. January 2009 18:18

Sobald ich eine .htaccess schreibe zeigt der server direckt Zugriff verweigert .

Du meinst beim Abspeichern der ".htaccess", oder beim Aufrufen einer Webseite nach dem Abspeichern einer ".htaccess"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 19:38

wenn ich die via winscp speichere direkct nach dem speichern steht dan auf der seite zugriff verweigert


Das ist hier was in meiner .htaccess drin steht.

Code: Select all
RewriteEngine on
RewriteBase /
RewriteRule stats-(.*).png$ ./benutzercenter.php?id=$1&userbanner=1
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby Wiedmann » 21. January 2009 19:40

direkct nach dem speichern steht dan auf der seite zugriff verweigert

Dann wird wohl in der ".htaccess" der Zugriff gesperrt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 19:41

das hier steht da drinn .htaccess


Code: Select all
RewriteEngine on
RewriteBase /
RewriteRule stats-(.*).png$ ./benutzercenter.php?id=$1&userbanner=1
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby Wiedmann » 21. January 2009 20:11

Oder leitet dich wohin um, worauf du keinen Zugriff hast. Schau dir mal das error_log vom Apache an.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 20:15

wo finde ich den error log
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby Wiedmann » 21. January 2009 20:17

Das sollte der Serveradmin wissen...

(normal irgendwo in /var/logs)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 20:47

da ist nur die übliche fehler meldung von gwbbcode aber der funtzt.
Code: Select all
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:40:01 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:40:02 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:40:02 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:40:02 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:40:07 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/index.php?forum-showposts-551-p1
[Wed Jan 21 20:40:07 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum-showposts-551-p1
[Wed Jan 21 20:40:07 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum-showposts-551-p1
[Wed Jan 21 20:40:08 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum-showposts-551-p1
[Wed Jan 21 20:43:49 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/
[Wed Jan 21 20:43:49 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:43:49 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:43:49 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/
[Wed Jan 21 20:46:09 2009] [error] [client 79.247.96.15] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:46:10 2009] [error] [client 79.247.96.15] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:46:10 2009] [error] [client 79.247.96.15] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
[Wed Jan 21 20:46:11 2009] [error] [client 79.247.96.15] File does not exist: /var/www/web1/html/{GWBB_STATIC_URL}, referer: http://gw-gral.de/index.php?forum
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby kynetix90 » 21. January 2009 20:48

nichts das der zugriff auf die htaccess irgend was ist.
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby kynetix90 » 23. January 2009 17:01

Wollte nur mal fragen ob mir hier noch geholfen wird oder ob das wieder so ein forum ist wo man nur abgewiesen wird ?


Könte vieleicht mein prob an der config von apache liegen zufällig ?
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Re: Probleme mit der .htaccess

Postby glitzi85 » 23. January 2009 17:18

Welche Fehlermeldung kommt denn im Browser genau? Ein Problem diesbezüglich kann ich in deiner error.log auch nicht feststellen. Bitte auch noch das access.log posten.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Probleme mit der .htaccess

Postby Wiedmann » 23. January 2009 20:05

Code: Select all
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/

Ein Problem diesbezüglich kann ich in deiner error.log auch nicht feststellen.

Also wenn jeder "Zugriff verweigert" in eben so einem Logeintrag resultiert, ist das Problem doch offentsichtlich.

(Allerdings hat er aber auch geschrieben, dass dies der übliche Fehler ist, der also auch bei einem normal Laufendem System kommt...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit der .htaccess

Postby glitzi85 » 23. January 2009 22:43

Wiedmann wrote:
Code: Select all
[Wed Jan 21 20:39:54 2009] [error] [client 217.255.90.85] File does not exist: /var/www/web1/html/{gwbbcode_root_path}, referer: http://gw-gral.de/

Ein Problem diesbezüglich kann ich in deiner error.log auch nicht feststellen.

Also wenn jeder "Zugriff verweigert" in eben so einem Logeintrag resultiert, ist das Problem doch offentsichtlich.

Eben nicht. Als Zugriff verweigert erwarte ich eigentlich einen Code 403, die Logeinträge kommen aber offensichtlich von einem Code 404. Deshalb wäre es interessant zu wissen welche Fehlermeldung denn nun genau kommt.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Probleme mit der .htaccess

Postby kynetix90 » 24. January 2009 16:08

also im dem err_log kommt halt nur dies und die seite zeigt nur an wenn ich die .htaccess einschalte "Zugriff verweigert"
kynetix90
 
Posts: 13
Joined: 21. January 2009 17:53

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests