Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Alles, was den Apache betrifft, kann hier besprochen werden.

Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Postby Gast85 » 19. January 2009 12:08

Hallo!

Nach vielen Versuchen ist es mir endlich gelungen, den Apache Webserver erfolgreich! auf meinem Computer zu installieren.
Ich benutze als Betriebssystem Windows Vista Home Edition.

Laut "Apache Monitor" läuft der Webserver.

Auch das Testdokument index.html im Apache-Ordner htdocs wurde im Browserfenster (ich benutze den Internet Explorer) vollständig angezeigt:
"It works!"


Also sollte der Webserver doch eigentlich funktionieren ...?!


Als ich dann versucht habe, ein php-Dokument mit Apache anzeigen zu lassen, bekam ich im Browserfenster jedoch eine Fehlermeldung:
Es handelt sich um den Fehler "HTTP-403 Verboten".

Dort steht dann z.B. auch:
"Wahrscheinlichste Ursachen: Diese Website erfordert, dass Sie sich anmelden."


Im Error Log von Apache steht als Fehler folgende Angabe:
[client 127.0.0.1] (20023)The given path was above the root path: Cannot map GET /D:/Apache2.2.10/htdocs/test.php HTTP/1.1 to file



Nun ja.
Ich weiß eigentlich wirklich nicht mehr so recht, was ich machen soll.
XAMPP habe ich auch schon öfters installiert und wieder deinstalliert.
Dort hatte ich bei Apache immer Probleme mit dem Befehl "make_sock" ..


Wie gesagt, Apache (ohne XAMPP) "läuft" ja.
Nur, wohl nicht nicht ganz vollständig und reibungslos.


Kann mir evtl. jemand helfen, mit dem oben beschriebenen Problem?!


Das wäre wirklich super!!



Vielen Dank schon mal im Voraus!



VLG,
Kathrin
Gast85
 
Posts: 8
Joined: 19. January 2009 11:48

Re: Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Postby Wiedmann » 19. January 2009 12:41

Als ich dann versucht habe, ein php-Dokument mit Apache anzeigen zu lassen,

Wie hast du das genau versucht? (welche URI)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Postby Gast85 » 19. January 2009 13:54

Mit der internen Seitenvorschau des Html-Editors phase 5.6.

Dort kann einstellen, wie man die Seite gerne anzeigt haben möchte.
Ich hab' dann als Webserver http://localhost angegeben.
Bzw. http://127.0.0.1.
Da ist kein Unterschied.
Sind beide irgendwie "Standard".


phase 5.6 öffnet dann ein Fenster und versucht folgende URL anzuzeigen, z.B.:

http://localhost/D:/Apache2.2.10/htdocs/test.php


Und dann kommt eben die HTTP-403 Verboten-Fehlermeldung ..


Wenn ich test.php gleich vom Ordner htdocs aus starte, und als Startprogramm für php-Dokumente den Internet Explorer einstelle, krieg' ich zwar die Option (PopUp), ob ich das test.php öffnen möchte, doch geöffnet wird das Dokument nicht.
Stattdessen krieg' ich immer wieder diesen PopUp ..

Das Dokument wird NICHT angezeigt bzw. "gelesen"?!



Hm.
Irgendeine Einstellung stimmt wohl noch nicht?
Gast85
 
Posts: 8
Joined: 19. January 2009 11:48

Re: Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Postby Wiedmann » 19. January 2009 14:54

phase 5.6 öffnet dann ein Fenster und versucht folgende URL anzuzeigen, z.B.:
http://localhost/D:/Apache2.2.10/htdocs/test.php

Diese Datei ("D:/Apache2.2.10/htdocs/test.php"), falls vorhanden, kannst du in deinem Webbrowser über die URI "http://localhost/test.php" aufrufen.

Mit der internen Seitenvorschau des Html-Editors phase 5.6.
...
Irgendeine Einstellung stimmt wohl noch nicht?

Soweit es diesen Editor, und dessen Konfiguration, angeht, solltest du dich an den Support dieser Software wenden (oder Handbuch lesen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Anzeige eines php-Dokuments mit Apache: HTTP-403 Verboten?!

Postby Anime » 15. January 2010 22:41

Schade das hier nicht näher drauf eingegangen ist, liegt vielleicht auch am Themen Starter!
Ich habe einen ähnlichen Fehler gehabt sogar wenn ich die URL im Browser aufrief.
Es verhielt sich ähnlich, ich bekam die selbe Fehlermeldung und in der URL stand plötzlich Localhost und das Verzeichnis was logischerweise mit einer Fehlermeldung endet.

Bei mir lagen andere Gründe vor die ich mir nicht ganz erklären kann.
Ich wollte per ModRew eine Weiterleitung für die Suchmaschinen Realisieren weil wir demnächst ein Foren Update umsetzen. So kommt es eben vor das die alten Themen und Beiträge demnächst nicht mehr unter der "thread.php" erreichbar sind sondern unter der "index.php?page=Thread". Dazu fand ich im Woltlab F folgende Hilfe:

## WBB2 Links
# Interne Links aus WBB2-Zeiten
RewriteRule ^thread\.php$ index.php?page=Thread [QSA,R=301,L]
RewriteRule ^board\.php$ index.php?page=Board [QSA,R=301,L]

Als ich dann versuchte gleiches umzusetzen sowohl auf meinen Privat Server daheim als auch bei meinen Provider, bekam ich die benannte Fehlermeldung mit der falschen URL.

Nach langen hin und her, lesen probieren und testen fand ich dann die Lösung und weiß nicht warum :shock:
In dieser Mod Rew Regel fehlt der Slash und funktionierte erst nach dem ich folgendes abänderte:

## WBB2 Links
# Interne Links aus WBB2-Zeiten
RewriteRule ^thread\.php$ /index.php?page=Thread [QSA,R=301,L]
RewriteRule ^board\.php$ /index.php?page=Board [QSA,R=301,L]

Vielleicht kann mir jemand erklären warum....
Herzlichen Dank
Anime
 
Posts: 44
Joined: 16. May 2006 18:48


Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests