Apache Subdomain und SSL Konfiguration

Alles, was den Apache betrifft, kann hier besprochen werden.

Re: Apache Subdomain und SSL Konfiguration

Postby glitzi85 » 16. January 2009 15:33

Wie schon von Wiedmann gefragt: Was tut nicht?

Außerdem hast du einen Fehler in der Konfiguration. ServerName wird ohne Protokoll definiert. Müsste also so aussehen:

Code: Select all
ServerName www.example.com


Außerdem hoffe ich, dass du es für die zweite IP NICHT exakt identisch aufgebaut hast. Mindestens ServerName sollte sich unterscheiden.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Apache Subdomain und SSL Konfiguration

Postby xampp112 » 16. January 2009 16:21

Nun es geht einfach nur aus dem internen Netz, dass ich die Hosts aufrufe. ->http://192.168.110.10 -> wunderbar und auch https://192.168.110.10

Wenn ich von extern etwas aufrufe, dann reagiert der Server auf den Port 80 gar nicht (Seite nicht gefunden) und wenn ich die https Adresse
nehme, dann lande ich immer im identischen Homeverzeichnis (dem von Host 192.168.110.10:443).

Deswegen habe ich ersteinmal die zweite Adresse herausgenommen, wenn es schon nicht klappt von extern auf zwei verschiedene Homeverzeichnisse zu verweisen.

Die Konfig ist nun :

Listen 192.168.110.10:80
Listen 192.168.110.10:443

<VirtualHost 192.168.110.10:443>
# General setup for the virtual host
DocumentRoot "D:/xampp/htdocs/ssl_110.10"
ServerName http://www.meinserver.de
ServerAdmin meine@mail.de
SSLCertificateFile conf/ssl.crt/mein.crt
SSLCertificateKeyFile conf/ssl.key/mein.key
<VirtualHosts>

<VirtualHost 192.168.110.10:80>
# General setup for the virtual host
DocumentRoot "D:/xampp/htdocs/no_ssl_110.10"
ServerName http://www.meinserver2.de
ServerAdmin meine@mail.de
<VirtualHosts>

Nun für dieselbe IP muss der Servername doch gleich sein oder?
xampp112
 
Posts: 16
Joined: 12. January 2009 11:32

Re: Apache Subdomain und SSL Konfiguration

Postby xampp112 » 17. January 2009 21:49

So, ich habs zumindest im internen Netz schoneinmal geschafft, dass der Apache auf die Anfragen korrekt antwortet.

IP1 = Seite 1
IP2 = Seite 2

von extern ruft er mir aber immer die Seite 1 auf... hat jemand eine Idee woran dies liegen kann?
xampp112
 
Posts: 16
Joined: 12. January 2009 11:32

Re: Apache Subdomain und SSL Konfiguration

Postby glitzi85 » 18. January 2009 23:45

Logisch. Auf welche IP hast du denn Port 80 weitergeleitet? Wenn du dir nicht eine zweite Internetleitung zulegen willst, dann geht das einfach nicht.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Previous

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests