Umlaut-Problem mit Apache unter Linux

Alles, was den Apache betrifft, kann hier besprochen werden.

Umlaut-Problem mit Apache unter Linux

Postby distefano » 31. December 2008 16:33

Hallo,
habe ein wohl sehr häufig auftretendes Problem, welches sich jedoch irgendwie trotz langer Forensuche und ausprobieren nicht lösen lässt.

Folgendes:
Ich habe einen Apache2 unter Fedora Linux laufen. Dabei habe ich ein Problem mit den Umlauten in Dateien die ANSI-codiert sind. D.h. speichere ich die Datei als UTF-8, kann ich in den HTML Dateien ganz normal Umlaute verwenden und sie werden auch dargestellt. Kodiere ich das ganze jedoch als ANSI, zeigt er mir statt einem Umlaut im Firefox nur eine Raute mit einem ? drin bzw. im IE ein leeres Rechteck an.

Auch der Quelltext beinhaltet die falschen Zeichen bei einer ANSI kodierten Datei.

Hab schon einiges ausprobiert, auch in der httpd.conf des Servers ein AddDefaultCharset auf ISO-8859-1 und so weiter. Leider ohne Erfolg (ja, Apache wurde nachher neu gestartet).
Auch die Angabe eines Content Types in den Meta Tags einer HTML Datei bringt keine Änderung.

Die Lösung wäre nun, alles auf UTF-8 umzustellen. Das will ich aber nicht, da wir eine PHP Software eines anderen Anbieters installieren wollen, dessen Dateien grundsätzlich ANSI kodiert sind, und bei einem Update wieder alle Dateien umcodiert werden müssten.

Umlaute und Kodierungen sind ein leidiges Thema. Habt ihr eine Idee, wie ich das Problem bei mir aus der Welt schaffen kann?

Danke im Voraus!

UPDATE:
hier noch der Header der bei einer simplen Seite zurück kommt:

Date: Wed, 31 Dec 2008 15:35:55 GMT
Server: Apache/2.2.3 (CentOS)
Last-Modified: Wed, 31 Dec 2008 14:09:53 GMT
Etag: "2843994-85-4304ee40"
Accept-Ranges: bytes
Content-Length: 133
Content-Type: text/html; charset=utf-8
Content-Language: de

200 OK


und die Seite die angezeigt werden soll

Code: Select all
<html>
<head>
   <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
</head>

<body>
   <p>Ü Ä Ö</p>
</body>
</html>
distefano
 
Posts: 1
Joined: 31. December 2008 16:18

Re: Umlaut-Problem mit Apache unter Linux

Postby Wiedmann » 31. December 2008 21:07

Code: Select all
Content-Type: text/html; charset=utf-8

Dann solltest du mal schauen, wer oder was diesen Header setzt...

(Bei einem ANSI kodiertem Content und diesem Header kann nur Mist rauskommen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests