Satisfy Any Satisfy All in einer Directive kombinierbar?

Alles, was den Apache betrifft, kann hier besprochen werden.

Satisfy Any Satisfy All in einer Directive kombinierbar?

Postby pv » 13. November 2008 18:27

Ist das mit Apache Bordmitteln in einer Conf zu lösen?

Gegeben ist folgendes Konstrukt:
<Location /geheim>
AuthType Basic
AuthName "geheimer Bereich"
AuthUserFile /srv/www/secrets/benutzer.pass
<Limit GET POST>
require valid-user
</Limit>
Allow from 111.111.111.111
Allow from 222.222.222.222
Deny from all
Satisfy Any
</Location>
In benutzer.pass ist ein Benutzer eingetragen. (benutzer1)

Mit dieser Konfiguration kann man nur auf "geheim" zugreifen, wenn man entweder von einer der beiden IPs kommt oder (Satisfy Any) die korrekten Zugangsdaten des Benutzers kennt, was auch ok ist.

So jetzt kommts:

Zusätzlich soll ein weiterer Benutzer (benutzer2) Zugriff auf den Bereich erhalten, wenn er aus dem Netz 121.121.121.121 kommt, sonst nicht. (Satisfy All)

Ich bezweifle, dass das in der selben Directive möglich ist.
Hat jemand einen Tipp dazu?
pv
 
Posts: 5
Joined: 13. November 2008 16:52

Re: Satisfy Any Satisfy All in einer Directive kombinierbar?

Postby glitzi85 » 15. November 2008 02:36

pv wrote:Ich bezweifle, dass das in der selben Directive möglich ist.
Hat jemand einen Tipp dazu?

Da bezweifelst du richtig. Für komplexe Authentifizierungen ist diese Methode nicht gedacht. Du könntest also eine zweite Direktive schreiben oder das ganze in eine Serverseitige Programmiersprache verlagern. Evtl. könntest du mal versuchen ob das ganze auch mit mod_authn_alias machbar wäre: http://httpd.apache.org/docs/2.2/mod/mo ... alias.html
Da steht zwar nur ein LDAP Beispiel, aber statt LDAP könntes ja mal basic versuchen. Ist aber nur ein Schuss in's blaue, hab hier auch gar nicht die Möglichkeit das großartig zu testen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby pv » 17. November 2008 14:59

Danke für den Tipp, aber leider derzeit nicht durchführbar, da ich noch Apache 2.0.x einsetze. :(

Compatibility: Available in Apache 2.1 and later

Ich behalte es im Hinterkopf... :wink:
pv
 
Posts: 5
Joined: 13. November 2008 16:52


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests