Gelöst: FollowSymLinks will ums Verrecken nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Gelöst: FollowSymLinks will ums Verrecken nicht

Postby to2 » 30. October 2008 17:01

Hallo,

auf Opensuse 10.3 habe ich Apache/2.2.4 installiert. In /srv/www/htdocs habe ich 2 Verzeichnisse mit einigen Symlinks drin, die von einem Verzeichnis ins andere zeigen (Typo3-Installation).

Die Symlinks stimmen, auf der shell kann ich entsprechend damit hantieren. Beim Zugriff auf das Verzeichnis bekomme ich im Browser:
Error 403

und im apache log:
Symbolic link not allowed or link target not accessible: /srv/www/htdocs/dummy.

Ich habe inzwischen die httpd.conf folgendermaßen zugeballert:

Code: Select all
<Directory "/srv/www/htdocs">
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<Directory "/srv/www/htdocs/typo">
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<Directory "/srv/www/htdocs/typo3_src-4.1.3">
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<Directory "/srv/www/htdocs/dummy">
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<Directory "/srv/www/htdocs/dummy-4.1.3">
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>


Das +SymLinksIfOwnerMatch hatte ich wahlweise auch mal nicht drin, war eine der letzten Aktionen. Dazu am Ende der httpd.conf noch mal ein
Options +FollowSymLinks reingepackt. Und immer schön /etc/init.d/apache2 restart.

Ums Verrecken will mir apache nicht die Seite ausliefern. Zugriffsproblem schließe ich an sich aus. Wenn ich direkt in dem Verzeichnis eine Datei platziere und die ohne Linknamen zu benutzen in der Browserzeile adressiere, dann erscheint die auch.

Muss also an dem FollowSymLinks liegen und ich bin mit meinem nur rudimentär vorhandenen Apachewissen nach 5 Stunden googeln und Probieren am Ende.

Wie soll ich weiter vorgehen?
Last edited by to2 on 30. October 2008 21:25, edited 1 time in total.
to2
 
Posts: 2
Joined: 30. October 2008 15:35

Postby to2 » 30. October 2008 21:24

Viel hilft nicht immer viel. Nach diesen Direktiven wurde weiter unten noch eine default-server.conf included. Und die sagte erstmal wieder:

Code: Select all
<Directory "/srv/www/htdocs">
Options none
 [...]


Da kann man vorher soviel FollowSymLinks schreiben wie man will, wenn danach wieder alles ausgeschaltet wird.
to2
 
Posts: 2
Joined: 30. October 2008 15:35


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests