suse linux 11 error

Alles, was den Apache betrifft, kann hier besprochen werden.

suse linux 11 error

Postby cschwank » 17. October 2008 13:49

hallo,

dies ist mein erster post in diesem forum und gleichzeitig mein erstes problem mit apache ;) und zwar habe ich suse linux 11 laufen und bekome folgenden error in der console.

Wenn ich rcapache2 restart eingebe bekomme ich folgenden fehler:

Code: Select all
rcapache2 restart
httpd2-prefork: Syntax error on line 116 of /etc/apache2/httpd.conf: Syntax error on line 29 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib/apache2-prefork/mod_proxy_ajp.so into server: /usr/lib/apache2-prefork/mod_proxy_ajp.so: undefined symbol: proxy_module


jemand ne idee woran das liegen könnte? Sorry aber ich bin totaler apache newbie!

ciao
chris
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 17. October 2008 20:26

Wenn du "mod_proxy_ajp" benutzen willst, musst du auch "mod_proxy" aktivieren (das muss in der loadmodule.conf zuerst geladen werden).

(Bei Suse gibt's da aber IMHO ein Systemkommando um Apachemodule zu aktivieren.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 20. October 2008 12:14

aber in der datei loadmudule.conf steht es doch drin!?:

Code: Select all
LoadModule proxy_ajp_module                              /usr/lib/apache2-prefork/mod_proxy_ajp.so


liegt denn der fehler nicht eventuell woanders?
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 20. October 2008 12:18

aber in der datei loadmudule.conf steht es doch drin!?:

Ich sehe da kein "mod_proxy"...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 20. October 2008 12:32

vielleicht sollte ich den fehler generell komlett ausschreiben, eventuell war der weg vorhin auch falsch. der der error der kommt sieht genau so aus nachdem ich "rcapache2 start" eingebe:

Code: Select all
Starting httpd2 (prefork) httpd2-prefork: Syntax error on line 116 of /etc/apache2/httpd.conf: Syntax error on line 29 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib/apache2-prefork/mod_proxy.ajp.so into server: /usr/lib/apache-prefork/mod_proxy_ajp.so: undefined symbol: proxy_module

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 20. October 2008 12:50

vielleicht sollte ich den fehler generell komlett ausschreiben,

Der Fehler war schon klar zu erkennen.

Aber um es deutlicher zu machen:
"mod_proxy" ist etwas anderes als "mod_proxy_ajp".

Wenn man "mod_proxy_ajp" laden will, muss man aber zuvor "mod_proxy" laden. Und das passiert bei dir nicht. (Bei dir wird nur "mod_proxy_ajp" geladen, nicht aber auch "mod_proxy".)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 20. October 2008 13:00

sry ich bin echt ein noob aber wie lade ich das!?
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 20. October 2008 13:20

aber wie lade ich das!?

Code: Select all
LoadModule proxy_module /usr/lib/apache2-prefork/mod_proxy.so
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 20. October 2008 14:20

kann es sein das ich apache komplett neu installieren muss, denn wenn ich das so reinschreibe das es vor dem mod_proxy_ajp geladen wird bekomme ich den error immernoch und wenn ich dann die loadmodule.conf wieder öffne hat sich die reiehenfolge wieder verstellt...
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 20. October 2008 14:30

und wenn ich dann die loadmodule.conf wieder öffne hat sich die reiehenfolge wieder verstellt...

Wie oben schon geschrieben, hat Suse IMHO ein eigenes Systemkommando um Apachemodule zu aktivieren.

Ergo sollte man das dann damit machen. (Allerdings bist du hier der Suseuser und solltest das damit besser wissen ;-) )
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 21. October 2008 07:51

okay ich hab des modul zum laufen bekommen und zwar mit dem befehl:
Code: Select all
a2enmod mod_proxy
aber wenn ich nun eingebe
Code: Select all
rcapache2 start
bekommeich folgenden fehler ausgegeben:

Code: Select all
Starting httpd2 (prefork) [Aktuelles Datum] [warn] module proxy_module is already loaded, skipping Syntax error on line 5 of /etc/apache2/conf.d/proxy.ajp.conf: ProxyPass|ProxyPassMatch can not have a path when defined in a location.

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf


was könnte denn jetzt noch sein?
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 21. October 2008 08:21

Das sind 2 verschiedene Meldungen:
Code: Select all
module proxy_module is already loaded, skipping

Anscheinend gibt es jetzt 2x ein "Load Module proxy_module ...". Eines davon musst du wieder entfernen (evtl. das, was du von Hand reingeschrieben hast?).

Code: Select all
Syntax error on line 5 of /etc/apache2/conf.d/proxy.ajp.conf: ProxyPass|ProxyPassMatch can not have a path when defined in a location.

In dieser Datei benutzt du ProxyPass oder ProxyPassMatch falsch. (Darf innerhalb eines "Location" Block nicht mit einem Pfad als Parameter benutzt werden.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 21. October 2008 08:31

okay, den error mit dem doppelten modul habe ich wegbekommen und in der datei proxy.ajp.conf steht in zeile 5 folgendes:

Code: Select all
ProxyPass /axis2 ajp/ http://127.0.0.1:8009/axis2 smax=0 ttl=60 retry=5
was ist daran denn falsch?
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Postby Wiedmann » 21. October 2008 08:52

was ist daran denn falsch?

Wiedmann wrote:Darf innerhalb eines "Location" Block nicht mit einem Pfad als Parameter benutzt werden.)

Da wohl innerhalb eines Location Blocks:
Code: Select all
ProxyPass http://127.0.0.1:8009/axis2 smax=0 ttl=60 retry=5

(BTW hattest du auch 2 Pfade angegeben, was von vorneherein falsch ist. Aber das hatte der Apache dann nicht mehr bemängelt/überprüft.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cschwank » 21. October 2008 09:01

okay, jetzt habe ich meien datei so editiert und es schein to als käme ich schritt für schritt näher an mein ziel dank deiner sehr guten infos!

der nächste fehler der nun kommt ist folgender:

Code: Select all
Starting httpd2 (prefork) Syntax error on line 1 of /etc/apache2/vhosts.d/ox.conf:
Invalid command 'meVirtualHost', perhaps misspelled or defined by a module not included in the server configuration

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf


der inhalt der datei sieht so aus:

Code: Select all
meVirtualHost*
<VirtualHost* >
        ServerAdmin webmaster@localhost

        DocumentRoot /srv/www/htdocs/

        <Directory /srv/www/htdocs/>
                AllowOverride None
                Order allow,deny
                allow from all
                RedirectMatch ^/$ /ox6/
        </Directory>

        ExpiresActive On
        ExpiresByType image/gif "access plus 23 hours"
        ExpiresByType image/png "access plus 23 hours"
        ExpiresByType image/jpg "access plus 23 hours"
        ExpiresByType image/jpeg "access plus 23 hours"
        ExpiresByType text/javascript "access plus 23 hours"
        ExpiresByType text/css "access plus 23 hours"
        ExpiresByType text/html "access plus 23 hours"
        ExpiresByType application/x-javascript "access plus 23 hours"
        <Files ~ "\.(js|css|gif|jpe?g|png)$">
                Header append Cache-Control "public"
        </Files>

        DeflateFilterNote ratio
        AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-javascript
        BrowserMatch ^Mozilla/4 gzip-only-text/html
        BrowserMatch ^Mozilla/4\.0[678] no-gzip
        BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
        Header append Vary User-Agent env=!dont-vary
</VirtualHost>


ist hier ein fehler für geübte augen erkennbar?
User avatar
cschwank
 
Posts: 9
Joined: 17. October 2008 13:46

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests