Mal wieder die .htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

Mal wieder die .htaccess

Postby Stoertebeker76 » 03. May 2008 08:49

Hallo zusammen,

folgende Herausforderung:

Seit vielen Stunden bin ich auf der Suche nach ner Lösung für mein .htaccess Problem. - Die htaccess will einfach nicht greifen.

Konfiguration:
Suse 10.3 / apache2

httpd.conf
......................
# forbid access to the entire filesystem by default
<Directory /srv/www/htdocs>
Options None
AllowOverride All
Order allow,deny
allow from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>
....................

.htaccess
AuthType Basic
AuthName "HTDOCS"
AuthUserFile /srv/www/htdocs/.passwords
Require valid-user
Order deny,allow


mein ziel ist es, alles was unter /....../htdocs liegt mit einer User/passwort Abfrage zu schützen. - Bisher erreiche ich allerdings alles ohne die Schutzfunktion.

Ich wäre über Eure Hilfe sehr dankbar!!!

Viele Grüße aus dem sonnigen Süden Deutschlands.
Stoertebeker76
 
Posts: 3
Joined: 03. May 2008 08:41
Location: Stuttgart

Postby Nobbie » 03. May 2008 10:33

Was soll denn diese verlorene "Order deny,allow"-Zeile am Ende bewirken?
Lass die mal weg.

Du könntest diese Zeilen auch direkt in die httpd.conf schreiben, in die <directory ...> Anweisung für /srv/www/htdocs, wenn Du sie sowieso für die ganze htdocs haben willst.

Leider erzählst auch Du uns nicht, was denn nun eigentlich genau passiert.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby Stoertebeker76 » 04. May 2008 16:42

Hallo Nobbie,

vielen Dank für Deine Antwort.
Hat leider zu keiner Verbesserung geführt.

Nach Aufruf der Seite wird die index-Datei innerhalb der HTDOCS ohne weiter Abfragen aufgerufen... :-(

Hast Du noch ne Idee?

Vielen Dank!
Stoertebeker76
 
Posts: 3
Joined: 03. May 2008 08:41
Location: Stuttgart

Postby Stoertebeker76 » 04. May 2008 18:32

Problem ist gelöst!

ich hab mich zu sehr auf die httpd.conf konzentriert.
Der Eintrag "AllowOwerride All" muss in die default-server.conf
(Suse 10.3)
-> jetzt läuft alles :-)


Vielen Dank.
Stoertebeker76
 
Posts: 3
Joined: 03. May 2008 08:41
Location: Stuttgart


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests