Einzelnes CGI mit Authentifizierung?

Alles, was den Apache betrifft, kann hier besprochen werden.

Einzelnes CGI mit Authentifizierung?

Postby ronny_fmso » 28. April 2008 18:40

Hallo Indianerfreunde,

Ich hab wiedermal was seltsames ;-)

Im cgi-bin-Verzeichnis einen virtuellen Servers unter Debian Etch liegen mehrere .cgi Scripte, die dort auch zusammenbleiben müssen.
Ich möchte nun aber auf einzelne davon nur mit Authentifizierung zugreifen lassen.
Also: >Files>-Container...

z.B:
Code: Select all
<Files cgi-bin/programm/login.cgi>
        AuthType Basic
        AuthName "Intern"
        AuthUserFile /etc/apache2/administration.htpasswd
        Require valid-user
</Files>


Geht aber nicht.
Ich hab das direkt in der apache.conf und auch im Abschnitt des entsprechenden VirtualHosts.
Die PW-Datei existiert.

Er lässt mich aber mit stetiger Boshaftigkeit ohne jedes PW rein ;-(

Wo ist mein Fehler?
Geht das nicht mit CGIs?
Fehlt was?
Falsche Stelle?

"Apache Webserver 2" von Wolfgarten kenn ich inzwischen fast auswendig *leichtübertreib:-)*, habs aber nicht hinbekommen...

Wer hat einen Tip?


Danke schonmal,

Schöne Grüße,


Ronny
ronny_fmso
 
Posts: 8
Joined: 28. March 2008 18:52
Location: Wurzen

Postby Xardas der Dunkle » 28. April 2008 18:56

Wieso versuchen momentan alle Authentifizierungen nur für einzelne Dateien zu erstellen?^^

Du kannst entweder das komplette Verzeichnis mit einem Passwortschutz versehen, aber keine Dateien ;).
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby Wiedmann » 28. April 2008 19:03

Xardas der Dunkle wrote:Wieso versuchen momentan alle Authentifizierungen nur für einzelne Dateien zu erstellen?^^

Weil eben dafür die Directive Files da ist...


ronny_fmso wrote:
Code: Select all
<Files cgi-bin/programm/login.cgi>

Files möchte einen Dateinamen haben, und nicht Pfad+Name.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ronny_fmso » 28. April 2008 19:36

Hallo Wiedmann,

Kling logisch, also ausprobiert:

Code: Select all
 <Directory "/var/www/........../cgi-bin/....../programm/">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch -Indexes
                Order allow,deny
                Allow from all
                <Files login.cgi>
                        AuthType Basic
                        AuthName Administration
                        AuthUserFile "/etc/apache2/administration.htpasswd"
                        Require valid-user
                </Files>
                <Files edit.cgi>
                        AuthType Basic
                        AuthName Administration
                        AuthUserFile "/etc/apache2/administration.htpasswd"
                        Require valid-user
                </Files>
        </Directory>


Jetzt kommt Fehler 500, im Fehlerlog steht trotz "debug" nix...
Der spinnt. Oder ich ;-)

Immerhin kann jetzt kein Unbefugter mer rein, aber ich auchnich ;-)

Ronny
ronny_fmso
 
Posts: 8
Joined: 28. March 2008 18:52
Location: Wurzen

Gelöst! Danke...

Postby ronny_fmso » 28. April 2008 19:43

Hallo,

profaner Ferschreiber beim Namen der PW-Datei. Bei der Datei, da hab ich nich nochmal kontrolliert ;-)
Und es stand auch im Log, nur in nem anderen. Da muss ich wohl die Fehlerlogs nochmal geraderücken...

Großes Danke für die Hilfe,

Ronny
ronny_fmso
 
Posts: 8
Joined: 28. March 2008 18:52
Location: Wurzen


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests