Download von Dateien aus dem Apache2 langsam

Alles, was den Apache betrifft, kann hier besprochen werden.

Download von Dateien aus dem Apache2 langsam

Postby masterbell » 28. April 2008 10:34

Hallo,

ich hätte da ein pikantes Problem.
Einer unserer Rechner war zu einem Test in einer Firma. Dort berichtete man mir, dass sie Problem bei Download von Dateien von einem Apache2 Server haben. Allerdings nicht nur mit unserem Rechner.
Ich hab den Rechner zurückbekommen und kann das Problem hier in meiner Testumgebung mit einem Apache2, auf dem unsere Dokuwiki läuft, nachvollziehen.
Download im Netz ist i.o. Download von der Microsoft Seite (XP SP3) ist auch ok. Wenn ich nun von unserer Dokuwiki das XP SP3 runterladen will, bekomme ich nur eine Downloadrate von knappen 300 kb, was eine Netzwerkauslastung von 2-3% entspricht. Hier kommt ein Agere Netzwerkchipsatz zum Einsatz.
Mit meinem Desktopsystem mit einem Intel Chipsatz habe ich das Problem nicht.
Kennt jemand das Problem?
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby Nobbie » 28. April 2008 15:39

Unabhängig davon, dass die Beschreibung grauenhaft schlecht ist, wie sieht es denn mit FTP aus und/oder mir Windows-Netzwerkverbindung?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Postby masterbell » 28. April 2008 16:27

Ich muss zugeben, die Beschreibung ist nicht besonders gut. Mittlerweile habe ich einige Testzyklen hinter mir und kann das Problem konkretisieren.

Testsysteme immer Intel mit Windows XP SP2

Erstes System mit einem Agere ET1310 Netzwerkchipsatz:

Beim Download einer Datei aus dem Intranet (Apache2 Server) gibt es eine maximale Downloadgeschwindigkeit von 360 KB/s. Dies entspricht etwas 2% Netzwerkauslastung. Alle anderen Downloads aus dem lokalen Netz oder per FTP sind OK, heißt bis zu 80% Netzwerkauslastung.
Das Phänomen mit dem langsamen Download tritt nur in Zusammenhang mit dem Apache2 auf.

Zweites System mit einem Intel Pro/100 PV:

Es treten die selben Probleme auf.

Drittes System mit einem Intel Pro/1000 PM:

Der Download aus dem lokalen Intranet (Apache2) liegt bei ca. 4 MBit/s. Ist also sehr schnell.

Viertes System mit einem Realtek Chipsatz:

Der Download aus dem lokalen Intranet erreicht eine Rate von ca. 500 KB/s. Entspricht etwa 5% Netzwerkauslastung.

Es scheint fast so, als wenn die Downloadgeschwindigkeit durch irgendwas gedrosselt wird.
Firewall ist deaktiviert, ein Virenscanner läuft auf den Testgeräten nicht.

Interessanterweise habe ich diese Performenzprobleme unter Linux nicht.

Auf diese Problematik bin ich durch einen Kunden gestoßen, welcher mir von diesem Problem berichtete. Bei denen läuft ein Röntgenbildssystem, welches per einem Apache2 Webserver die Bilder Digital zur Ansicht zur Verfügung stellt. Es ist also kein Problem, welches nur in meinem Netzwerk auftritt...ich habe es lediglich reproduzieren können. Es tritt auch noch mit anderen Netzwerkchipsätzen auf.

Ich hoffe das die Beschreibung nun ausreicht ;-)

Hat jemand eine Idee?
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby Nobbie » 28. April 2008 17:34

>Ich hoffe das die Beschreibung nun ausreicht

Ne, leider nicht.

Sind das direkte Downloads ohne Beteiligung irgendwelcher Scripts/CGI, oder sind das Downloads via PHP o.ä.?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Postby masterbell » 29. April 2008 07:26

Ja, direkte Downloads aus einem Verzeichnis.
Kein php oder sonstige Scriptsprachen.
Allerdings ist die Verlinkung in der Dokuwiki.
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby masterbell » 29. April 2008 09:11

Hat sich erledigt.
Ist anscheinend eine fehlerhafte sendfile-Unterstützung des Apache.
In meinem Fall anscheinend deswegen, weil ich das DocumentRoot über ein Netzwerk (SMB) eingebunden habe.

So stehts in der Doku...so funktioniert es auch

Bei per NFS oder SMB eingebundenen Dateien kann diese Funktion explizit für die störenden Dateien deaktiviert werden, indem Sie angeben:

Code: Select all
<Directory "/pfad-zu-den-nfs-dateien">
 EnableSendfile Off
</Directory>
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby Nobbie » 29. April 2008 10:55

masterbell wrote:Ist anscheinend eine fehlerhafte sendfile-Unterstützung des Apache.


Ne, das ist keine fehlerhafte sendfile-Unterstützung des Apachen, sondern das ist ein Fehler von Euch, wenn Ihr bei NFS und SMB diese Option nicht deaktiviert. Apache hat keine Möglchkeit festzustellen, ob der DocumentRoot eine Freigabe ist oder ein lokales Dateisystem. Und per Default ist die o.g. Option so eingestellt, dass der Kernel direkt die Dateien ausliefert, was für den IO prinzipiell besser ist, weil Apache die Datei selbst nicht einlesen und ausliefern muss.

Das funktioniert aber nicht bei SMB Freigaben und deswegen musst Du Apache mitteilen, dass das nicht geht.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Postby masterbell » 30. April 2008 07:00

sondern das ist ein Fehler von Euch


Nix Euch, ich bin alleine.

Allerdings ist es so, dass da einige Firmen dran verzweifen, weil Sie einen Standard Apache aufsetzen und sowas schlicht weg übersehen. Vor allem aus der Tatsache raus, dass es ja mit einigen Clients geht, mit anderen nicht.

Übrigens Nobbie...ich will dem Apache nix. Ich finde ihn selber gut, sonst würde ich ihn nicht einsetzten. Es können aber nicht alle überragende Apache Kenner sein. Ich habe hier ja nur Hilfe gesucht und im Grunde nix als Vorwürfe geerntet (..."grauenhaft schlecht"..."Fehler von Euch"). Steh mal annähernd unter dem Druck, den ich hier gehabt habe...

Da bleibt einem wieder nix als "hilf dir selbst". Eigentlich schade, weils nicht der Sinn eines Forums ist.
:evil:
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby masterbell » 30. April 2008 07:03

---
Stille Wasser sind tief
und verdammt dreckig
masterbell
 
Posts: 6
Joined: 28. April 2008 10:25

Postby shinebar » 28. August 2008 15:15

Zu Dokumentationszwecken:

Auf W2k3 mit Apache 2.0.63 und 2.2.9 hatte ich dieses Problem auch (Download von AVI-Dateien bei ~300KB/sec) - obwohl mein Document Root auf einer lokalen Platte lag.

Die Deaktivierung des SendFile Supports hat geholfen - nun flutschen wieder knapp 10MB/sec über die Leitung.

Vielen Dank!
shinebar
 
Posts: 1
Joined: 28. August 2008 15:11


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests