apache und debian etch

Alles, was den Apache betrifft, kann hier besprochen werden.

apache und debian etch

Postby mele » 16. April 2008 15:09

Hi zusammen,

habe folgendes prob: ich habe einen debian server aufgesetzt... apache2 mit dem befehl apt-get install apache2 installiert.... es kam keine fehlermeldung... allerdings habe ich unter /etc/ keinen apache2 ordner... ??!! weiß da jemand von euch rat? habs schon öfter installiert, aber iwie funzt dat dingens nich so wirklich... O.o

mfg

mele
mele
 
Posts: 9
Joined: 16. April 2008 15:06

Postby Nobbie » 16. April 2008 16:37

Schau mal statt nach apache2 nach httpd o.ä. - evtl. auch nur eine Datei httpd.conf

Gib mal "ls -ld /etc/http*" in einer Konsole ein, dann wirst Du sehen was es gibt.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Postby mele » 17. April 2008 08:53

hm... "Datei oder Verzeichnis nicht gefunden?! O.o ... och menno! :cry:
mele
 
Posts: 9
Joined: 16. April 2008 15:06

Postby mele » 17. April 2008 08:56

Also ich hab jetzt mal nur den "normalen" apache installiert und gestartet... das funktioniert soweit. Ich kenn den befehl für den Abruf des Status aber nur von suse mit rcapache status... wie frag ich den Status denn bei Debian ab?
mele
 
Posts: 9
Joined: 16. April 2008 15:06

Postby MADxHAWK » 18. April 2008 09:49

hi,

das ist in der tat ungewöhnlich da sich der Apache config bei Debian in /etc/apache2 befindet.

Bekommst Du denn eine Website angezeigt wenn du http://<serverip> aufrufst ?

Wenn du WinSCP nutzt aktualisiere mal das Verzeichnis (reload) da das Proggy die angewohnheit hat neue ordner / files erst dann anzuzeigen.

den Apache kannst du unter Debian mit

/etc/init.d/apache2 [start|stop|restart|reload|force-reload]

bedienen.

Greetz
MAD
MADxHAWK
 
Posts: 5
Joined: 18. April 2008 09:37

Postby mele » 21. April 2008 10:07

danke erstmal für deine antwort... also hab debian gerade mal mit apt-get remove apache2 deinstalliert und dann mit apt-get install apache2 noch mal installiert, aber iwie funzt dat nich.. der ordner /etc/apache2 wird gar nicht erst erstellt! O.o
mele
 
Posts: 9
Joined: 16. April 2008 15:06

Postby MADxHAWK » 21. April 2008 14:21

Hi,

das ist wirklich merkwürdig, aber schau mal hier:

http://www.tim-bormann.de/?section=145

Da findest Du eine sehr ausführliches Tutorial wie unter Etch Apache, PHP, mySQL usw. installiert und configuriert werden.

Hoffe das hilft Dir.

Gruss
MAD
MADxHAWK
 
Posts: 5
Joined: 18. April 2008 09:37

Postby mele » 22. April 2008 10:25

Vielen Dank für den Link! Der ist mal wirklich hilfreich! allerdings besteht mein Problem immer noch... Also... hab nochmal apt-get update gemacht und jetzt wurde (warum auch immer) die apache2.conf erstellt... allerdings ist diese leer!... kann man nachschauen was da standardmäßig rein muss? welche Ordner fehlen noch im /etc/apache2 ordner?
mele
 
Posts: 9
Joined: 16. April 2008 15:06

Postby MADxHAWK » 24. April 2008 20:02

versuch mal folgendes

apt-get --purge remove apache2
das deinstalliert den installierten apache KOMPLETT inc. der config dateien

apt-get clean
löscht alle mit apt-get install geholten packete aus /var/cache/apt/archives/ wo die packete abgelegt werden. Vieleicht gabs bei dir n fehler bei der übertragung.
So sollte sichergestellt werden das du ein neues Packet frisch runterlädst.

Greetz
MAD
MADxHAWK
 
Posts: 5
Joined: 18. April 2008 09:37

Postby mele » 13. May 2008 14:29

hm... das hat jetzt mein problem auch nicht lösen können. aber trotzdem vielen dank! ich glaube, ich werde den server einfach nochmal installieren. ist ja eh nur zum testen, aber hatte schon alles soweit installiert gehabt und es lief ja auch... naja, bleibt mir wohl nichts anderes übrig, kann ja auch nich schaden, wenn man des mal öfter macht! :P :D

mfg

mele
mele
 
Posts: 9
Joined: 16. April 2008 15:06


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests