ssi bei Apache2 aktivieren

Alles, was den Apache betrifft, kann hier besprochen werden.

ssi bei Apache2 aktivieren

Postby debianer » 24. February 2008 19:28

Hallo,

ich bin am Verzweifeln. Ein frisch installiertes Debian Etch mit Apache2. Ich schaffe es seit 2 Wochen nicht, ssi zu aktivieren. Dabei habe ich das in der Vergangenheit schon mehrmals erfolgreich macht, allerdings beim Apache1 in der httpd.conf. Die Doku auf apache.org ist veraltet und bezieht sich auf den Apache1. Alles Dokus die google so liefert habe ich erfolglos ausprobiert.

Kennt noch jemand eine funktionierende Anleitung?

Gruß
Andreas
debianer
 
Posts: 3
Joined: 24. February 2008 19:17

Postby Wiedmann » 24. February 2008 19:33

Die Doku auf apache.org ist veraltet

Das bezweifel ich doch stark. Aber möglicherweise dein Bookmark?

Unter httpd.apache.org findest du die Dokus für Apache1.x, Apache2.0.x, Apache2.2.x und für die Entwicklerversion (Trunk).

(BTS: Hast du wirklich noch den Apache2, oder doch einen Apache2.2?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby debianer » 24. February 2008 20:21

http://httpd.apache.org/docs/2.0/de/howto/ssi.html

Auf dieser Seite wird die Konfiguration noch in der httpd.conf vorgenommen. In der Datei steht ab Apache2x nichts mehr drin - sie dient nur noch der Abwärtskompatibilität.
debianer
 
Posts: 3
Joined: 24. February 2008 19:17

Postby Wiedmann » 24. February 2008 21:01

In der Datei steht ab Apache2x nichts mehr drin - sie dient nur noch der Abwärtskompatibilität.

Bei einem normalem (aus dem Sourcecode installiertem) Apachen steht da durchaus was drin.

Gerade aber unter Linux, haben die verschiedenen Distributionen ihre eigenen Vorstellungen, mit welchen Datein der Apache wo konfiguriert wird...

Allerdings ist letztendlich auch egal, wie die Datei heist, die Konfiguration funktioniert immer so, wie es im Apachemanual steht.

(Mal von Konfigoberflächen wie webmin usw. abgesehen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby debianer » 25. February 2008 17:29

Jetzt mal ernsthaft: Was soll ich mit diesen Antworten? Die helfen mir nicht im geringsten weiter.
debianer
 
Posts: 3
Joined: 24. February 2008 19:17

Postby Scory » 25. February 2008 17:59

Jetzt mal noch ernsthafter:

ich habe gerade innerhalb von 5 Minuten bei meinem Linux das SSI aktiviert - nach der Anleitung die "veraltet" sein soll. Bei mir geht sie.

Also Gegenfrage: was hast Du versucht, was hast Du wo eingetragen, wie hast Du das Resultat getestet?
Scory
 

Postby pauku1 » 04. May 2008 21:08

Hallo Gemeinde,
... also, bei mir hats mit den 5 Minuten auch nicht geklappt (wär auch ein Wunder bei einem Neuling wie mir).

Kurz und schmerzlos

was habe ich versucht?

Apache2.2.4 aus den Ubuntuquellen installiert


was habe ich wo eingetragen?

die letzten 4 Zeilen in der apache2.config

Code: Select all
ServerName localhost
Options +Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml


wie habe ich das Resultat getestet?

Code: Select all
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
  <meta http-equiv="Content-type" content="text/html; charset=iso-8859-1" />
  <title> test</title>
</head>

<body>

<p><!--#echo var="DATE_LOCAL" --></p>
<p> <!--#config timefmt="%A %B %d, %Y" --></p>
<p>Today is <!--#echo var="DATE_LOCAL" --></p>
<p> This document last modified <!--#flastmod file="index.html" --></p>

</body>
</html>


... Ergebnis: weißer Bildschirm.

Was mach ich falsch?
pauku1
 
Posts: 4
Joined: 04. May 2008 20:40

Nachfrage ssi

Postby pauku1 » 06. May 2008 09:50

hat denn keiner ein Erbarmen?

Ansonsten funktioniert der Server. Nur die ssi gehen nicht
Was tun?
pauku1
 
Posts: 4
Joined: 04. May 2008 20:40

Postby Nobbie » 06. May 2008 10:11

Nach welcher Dokumentation bist Du vorgegangen?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Postby pauku1 » 06. May 2008 11:23

Tach,

wie schon erwähnt bin newbie...

Auf dieser site fand ich die Grundlagen für ssi - und was man damit anstellen kann:

http://de.selfhtml.org/servercgi/server/ssi.htm

... und landete bei diesem howto:

http://httpd.apache.org/docs/2.2/howto/ssi.html

nach dem ich die obigen Schritte ausführte.

Der server funktioniert wie gesagt. Nur die ssi bekomme ich nicht hin.

Wenn ich die Seite http://localhost/neugma/index.shtml bei mir aufrufe, bekomme ich nur diese Ausgabe:


Today is

This document last modified


schonmal Danke
pauku1
 
Posts: 4
Joined: 04. May 2008 20:40

Postby pauku1 » 06. May 2008 19:56

Bin nun nach der Anleitung von Ubuntu:

https://help.ubuntu.com/community/ServerSideIncludes

vorgegangen. Damit klappt es.

Trotzdem Dank für eure Hilfe
pauku1
 
Posts: 4
Joined: 04. May 2008 20:40


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests