CGI-Programm kann nicht aufgerufen werden

Alles, was den Apache betrifft, kann hier besprochen werden.

CGI-Programm kann nicht aufgerufen werden

Postby hruehl » 24. February 2008 15:36

Hallo zusammen,

ich habe ein Programm im Verzeichnis /var/www/cgi-bin/abc/ (nach Vorlage) installiert, das mit xyz.cgi aufgerufen werden soll.

Bei Aufruf des Programms erscheint lediglich die Meldung "NOT FOUND".
Ich habe alle Rechte auf die Verzeichnisse und Dateien gesetzt; ich habe dem apache2 erlaubt, die CGI-Programme auszuführen (Execute cgi programms: yes (merge with parent; was heißt das?).

Kann jemand sagen, wie man den apache2 dazubringen kann, das Programm auszuführen?

Danke für die Hilfestellung!

Gruß

H. Rühl

PS: Ich denke, der apache2 läuft fehlerfrei; auf dem System ist. u. a. Typo3 und MediWiki installiert; beide laufen ohne Probleme.
hruehl
 
Posts: 2
Joined: 24. February 2008 15:25

Postby Wiedmann » 24. February 2008 19:30

(Execute cgi programms: yes (merge with parent; was heißt das?).

Da stellt sich die Frage, mit was für einem Programm konfigurierst du den Apache?

Kann jemand sagen, wie man den apache2 dazubringen kann, das Programm auszuführen?

Im Prinzip, bei normaler manueller Konfiguration des Apachen, musst du in der "httpd.conf" nur einen ScriptAlias für dein "cgi-bin" haben, im dazugehörigen Directory-Block ein "Allow from all" und das war es.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hruehl » 25. February 2008 11:36

Hallo,

zu 1. Ich habe den apache2 mit webadmin konfiguriert.

zu 2. ScriptAlias habe ich in die httpd.conf eingetragen, aber an den zweiten Teil habe ich nicht gedacht. Das wird es wohl gewesen sein.
Ich werde es ausprobieren.

Danke für die Hinweise.

Gruß

H. Rühl
hruehl
 
Posts: 2
Joined: 24. February 2008 15:25


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests